If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Move Mozilla Websites Privacy Policy Into Bedrock

VERIFIED FIXED in Future

Status

www.mozilla.org
Legacy PHP system
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: bensternthal, Assigned: openjck)

Tracking

(Blocks: 1 bug)

unspecified
Future
x86
Mac OS X
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: u=user c=redirect p=2 [kb=405324])

(Reporter)

Description

5 years ago
We want to consolidate the 2 existing privacy policy pages into 1 that will live in bedrock.

The two existing pages are:

http://www.mozilla.org/en-US/privacy-policy.html 
http://www.mozilla.org/about/policies/privacy-policy.html 

Complicating this are the redirects out there, below are the ones I found in the htaccess files. There might be others. Morgamic also suggested looking at the http logs just to be sure

/foundation/privacy-policy.html
/privacy-policy
/privacy-policy.html
(Reporter)

Updated

5 years ago
Duplicate of this bug: 773027
CCing Kaze since we were talking about which privacy link to use in gaia apps yesterday.
(Reporter)

Updated

5 years ago
Assignee: nobody → mkelly
(Reporter)

Updated

5 years ago
Assignee: mkelly → bsternthal
(Reporter)

Comment 3

5 years ago
note for me (ben) ckoehler wants me to check in on job application
(Reporter)

Updated

5 years ago
Depends on: 771146

Comment 4

5 years ago
We took the current draft to Harvey who wanted something a bit different. I'm planning on getting the draft of that to Harvey, Alex and everyone else this week. They will need some time with it before we get it out to you all. Basically, it's a redesign of the project. Will reach out with text soon.

Updated

5 years ago
Duplicate of this bug: 821030

Updated

5 years ago
Summary: Move Privacy Policy Into Bedrock → Move Mozilla Privacy Policy Into Bedrock

Updated

5 years ago
Summary: Move Mozilla Privacy Policy Into Bedrock → Move Mozilla Websites Privacy Policy Into Bedrock

Comment 6

5 years ago
Jishnu: Is the content on http://www.mozilla.org/en-US/privacy-policy.html still accurate where we can move it directly into the new /privacy sub-site on Mozilla.org? Thanks!

Comment 7

5 years ago
Assuming the privacy policy pages in comment 0 are the same and can be moved into the Bedrock privacy center, we will need to set up two redirects that goes from the two old URLs to the new one in the privacy center.

I propose this URL for the single websites privacy policy /privacy/websites/

Updated

5 years ago
Duplicate of this bug: 811440

Comment 9

5 years ago
Hi Guys,

My Comment 4 should not gate on this - I think it confused things and is wrong.

Consolidating the websites privacy policy would be awesome per Chris's Comment 7.

Thanks
Jishnu

Comment 10

5 years ago
(In reply to Jishnu Menon from comment #9)
> Hi Guys,
> 
> My Comment 4 should not gate on this - I think it confused things and is
> wrong.
> 
> Consolidating the websites privacy policy would be awesome per Chris's
> Comment 7.
> 
> Thanks
> Jishnu

Ok, so are we fine with moving the content 1:1 into Bedrock and redirecting both legacy URLs to /privacy/websites/?
Jbertsh has spoken with Jishnu and thinks cmore's plan (comment 10) is a go. So we just need to get this into the schedule. malexis, can we do it in March?
Flags: needinfo?(malexis)
Blocks: 656840
(Reporter)

Comment 12

5 years ago
I can do this in march, I don't think we need a developer assigned.. although I will have them review my code.
Flags: needinfo?(malexis)
(Reporter)

Comment 13

5 years ago
Schalk:

It looks like 

https://www-dev.allizom.org/b/en-US/privacy/policies/websites/

Is the page that I should redirect the above legacy pages too, but it looks like this code is not in production.

Can you give me an update on this page and where we are at?
Flags: needinfo?(sneethling)
(In reply to Ben (:bensternthal) from comment #13)
> Schalk:
> 
> It looks like 
> 
> https://www-dev.allizom.org/b/en-US/privacy/policies/websites/
> 
> Is the page that I should redirect the above legacy pages too, but it looks
> like this code is not in production.
> 
> Can you give me an update on this page and where we are at?

We have the main new privacy policy up at /privacy

I agree that the rest has been left behind and we need to change them to match, Jishnu? Thoughts?
Flags: needinfo?(sneethling)
(Reporter)

Comment 15

5 years ago
Jishnu:

Can you advise:

Basically we need to get:

https://www-dev.allizom.org/b/en-US/privacy/policies/websites/

Final and live.. we can then redirect the other old privacy pages here. Consolidating them and making everybody happy :)

If we sync the content from http://www.mozilla.org/en-US/privacy-policy.html to the new bedrock page... are we good to go on this?
Flags: needinfo?(jmenon)
(Reporter)

Comment 16

5 years ago
Jishnu, please advise on the above.

If I don't hear otherwise I will move forward with syncing the dev page with the current page and redirecting the two urls.
(Assignee)

Updated

4 years ago
Assignee: booboobenny+bugzilla → jkarahalis
There is a complete new implementation plan for the privacy policies and I think it is best to wait for feedback from Jishnu before implementing anything and pushing it to production.
:espressive, can you link to a bug describing the implementation plan you mention?

We have a Q2 goal to migrate mozilla.org content out of the PHP stack and into Bedrock (https://wiki.mozilla.org/Websites/Mozilla.org/Legacy-Migration). In many cases the content is in need of a refresh, and we are definitely ready to help content owners refresh and update their content when such updates are ready. Still, if we blocked migration anytime we found content in need of update, we'd be on PHP forever.

Is there a compelling reason to tightly bind the future of privacy policies to the present goal of serving mozilla.org content from a modern web framework with modern branding?
Flags: needinfo?(sneethling)
I've invited Jishnu to meet to discuss on May 29.
Hey guys - I don't want to block on your goals. We're hoping to have a new framework for all of our policies by the end of the quarter. Here's an example of the framework: https://www.mozilla.org/en-US/privacy/policies/firefox-os/. We'll be migrating all content and look and feel to this. If you need to get through the policies to meet your goal, that's fine, but it might be just a waste of time as we will change it within the next two quarters. Happy to talk to anyone I need to to explain the issue, but am fine if you're migrating the stuff off the old platform to make a goal or waiting for us to flip it.
Flags: needinfo?(jmenon)
So, I would suggest this. We need the content inside Bedrock, the new design/layout will be much closer to the current main privacy policy inside Bedrock then it will be to the various layouts on the PHP side so, I would suggest we migrate all of the content into Bedrock using the main privacy policy as the base template.

Once this is done, we can freely update the layout, content and design as needed. That way no one blocks no one and the additional work needed in, most likely Q3, will move quicker because the groundwork has already been laid down.

Thoughts?
Flags: needinfo?(sneethling)
(Reporter)

Comment 22

4 years ago
+1 sounds good.
Please let me know if I have this right. In concrete terms, we will ...

a) Create a new page in Bedrock containing this content: http://www.mozilla.org/en-US/privacy-policy.html
b) Put the new page at /en-US/privacy/policies/websites/
c) Use this page as the template for it: http://www.mozilla.org/en-US/privacy/
d) Put the PDF version (linked in HTML) in the same location
e) Redirect these URLs to the new location:
    * http://www.mozilla.org/about/policies/privacy-policy.html
    * http://www.mozilla.org/en-US/privacy-policy.html
f) Remove these files from SVN:
    * http://viewvc.svn.mozilla.org/vc/projects/mozilla.org/trunk/about/policies/privacy-policy.html?view=markup
    * http://viewvc.svn.mozilla.org/vc/projects/mozilla.com/trunk/en-US/privacy-policy.html?view=markup
    * http://viewvc.svn.mozilla.org/vc/projects/mozilla.com/trunk/en-US/privacy-policy.pdf?view=log
Whiteboard: u=user c=redirect p=2 → u=user c=redirect p=2 [kb=405324]
(Assignee)

Comment 24

4 years ago
I also have a question about copy. We currently have three versions of the policy -- one at /privacy-policy.html, one at /policies/privacy-policy.html, and the new page in-progress. The three pages are nearly identical, except that the advertising sections differ. Which of these should we go with, or should we go with some combination of them?

From http://www.mozilla.org/about/policies/privacy-policy.html

> Mozilla places advertisements on third party websites to introduce people to 
> our products and services, to encourage people to contribute to our 
> community-based activities, and to provide opportunities to sign up to 
> receive communications from Mozilla. We stand by our online advertising 
> practices and aim to provide full transparency and control over how our ads 
> appear and function.
> 
> Some advertisements may use cookies and/or clear GIFs. When you view 
> Mozilla's advertisements on third party sites where we advertise, cookies 
> and/or clear GIFs from these campaigns provide Mozilla with metrics to help 
> measure and improve performance of our advertising. We do not use cookies to 
> save data that identifies you personally, nor do we capture behavioral data 
> to personalize future ads or create targeting profiles about you. The domain 
> name in Mozilla ad cookies will clearly identify their affiliation with 
> Mozilla and/or, where applicable, our third-party service provider. For more 
> information on Mozilla’s third party service providers, click here.
> 
> Opting Out of Mozilla Ads
> 
> In the future, we hope to provide simple and comprehensive controls over our 
> ad practices, as well as ensure that these practices respond to the Do Not 
> Track signal enabled via Firefox and other browsers. For now, you may choose 
> to opt-out of first party Mozilla ad cookies by clicking on the following 
> link: Opt-Out Now. You may also wish to opt out of 3rd party ads here.
> 
> Social Networking Services
> 
> Mozilla may interact with you through social networks to further our mission. 
> When you interact with us at a third-party social network, such as Facebook, 
> Twitter, or Google +, the network gives us the ability to access and store 
> certain information from your profile for that social network.
> 
> The categories of information we can access will depend, in part, on the 
> permissions you grant us and the privacy settings you have established on 
> that social network. In general, we try to minimize the amount of data we 
> receive about you on social services. We will handle any information we 
> receive from these services in accordance with this privacy policy.

From http://www.mozilla.org/en-US/privacy-policy.html

> Mozilla places advertisements on third party websites to introduce people to 
> our products and services, to encourage people to contribute to our 
> community-based activities, and to sign up to receive communications from 
> Mozilla. We stand by our online advertising practices and aim to provide full 
> transparency and control over how our ads appear and function.
> 
> We use a vendor - TruEffect - to power our advertisements via the website 
> media.mozilla.com. Some advertisements associated with this site may use 
> cookies. Cookies are text files that your web browser places on your computer 
> when you visit a website and can be used to store information about your 
> activity. When you view Mozilla's advertisements on third party sites where 
> we advertise, cookies from these campaigns provide information to us that is 
> used to help measure and improve performance of our advertising. We do not 
> use cookies to save data that identifies you personally such as your name, 
> address, credit card number or other confidential information, nor do we 
> capture behavioral data to personalize future ads or create targeting 
> profiles about you.
> 
> Most browsers accept cookies automatically, but they can be configured not to 
> accept them or to indicate when a cookie is being set (see 
> http://www.allaboutcookies.org/manage-cookies/).
>
> SMS Text Messages
> 
> Mozilla provides an easy way to request an SMS text message with a link to 
> download Firefox for Android. The mobile phone number you provide will be 
> used and stored only for the purpose of sending requested communications and 
> providing abuse blocking.
> Social Networking Services
> 
> Mozilla may interact with you through social networks to further our mission. 
> When you interact with us at a third-party social network, such as Facebook, 
> Twitter, or Google +, the network gives us the ability to access and store 
> certain information from your profile for that social network.
> 
> The categories of information we can access will depend, in part, on the 
> permissions you grant us and the privacy settings you have established on 
> that social network. In general, we try to minimize the amount of data we 
> receive about you on social services. We will handle any information we 
> receive from these services in accordance with this privacy policy.

From https://www-dev.allizom.org/b/en-US/privacy/policies/websites/ (the new page in-progress)

> Mozilla places advertisements on third party websites to introduce people to 
> our products and services, to encourage people to contribute to our 
> community-based activities, and to provide opportunities to sign up to 
> receive communications from Mozilla. We stand by our online advertising 
> practices and aim to provide full transparency and control over how our ads 
> appear and function.
> 
> Some advertisements may use cookies and/or clear GIFs. When you view 
> Mozilla's advertisements on third party sites where we advertise, cookies 
> and/or clear GIFs from these campaigns provide Mozilla with metrics to help 
> measure and improve performance of our advertising. We do not use cookies to 
> save data that identifies you personally, nor do we capture behavioral data 
> to personalize future ads or create targeting profiles about you. The domain 
> name in Mozilla ad cookies will clearly identify their affiliation with 
> Mozilla and/or, where applicable, our third-party service provider. For more 
> information on Mozilla’s third party service providers, click here.
> Opting Out of Mozilla Ads
> 
> In the future, we hope to provide simple and comprehensive controls over our 
> ad practices, as well as ensure that these practices respond to the Do Not 
> Track signal enabled via Firefox and other browsers. For now, you may choose 
> to opt-out of first party Mozilla ad cookies by clicking on the following 
> link: Opt-Out Now. You may also wish to opt out of 3rd party ads here.
Hi All -

Please use the policy available here: http://www.mozilla.org/en-US/privacy-policy.html.

We need to update the portion of the policy regarding advertisements and are working on an update. For now, please use that version for the sandstone update.

Thanks
Jishnu
(In reply to Jishnu Menon from comment #25)
> Hi All -
> 
> Please use the policy available here:
> http://www.mozilla.org/en-US/privacy-policy.html.
> 
> We need to update the portion of the policy regarding advertisements and are...

So there is a the new policy here: https://www.mozilla.org/en-US/privacy/

At which URL should http://www.mozilla.org/en-US/privacy-policy.html live?
Flags: needinfo?(jmenon)
I think comment 23 covers all details necessary to complete this bug. 

> b) Put the new page at /en-US/privacy/policies/websites/
(Assignee)

Comment 28

4 years ago
My only question on comment 23 is about the template. You mention using [1], but that looks more appropriate for a landing page. Do we want to use [2] instead for the individual policies?

[1] http://www.mozilla.org/en-US/privacy/
[2] https://www-dev.allizom.org/b/en-US/privacy/policies/websites/
Flags: needinfo?(hoosteeno)
:openjck, good call. I like [2] in your list for the template: 

https://www-dev.allizom.org/b/en-US/privacy/policies/websites/
Flags: needinfo?(hoosteeno)
(Assignee)

Updated

4 years ago
Depends on: 878129
(Assignee)

Comment 30

4 years ago
PR @ https://github.com/mozilla/bedrock/pull/933

Opened bug 878129 for the cleanup work once that lands.
(Assignee)

Updated

4 years ago
Flags: needinfo?(jmenon)

Updated

4 years ago
Blocks: 879544
(Assignee)

Updated

4 years ago
Blocks: 878129
No longer depends on: 878129

Comment 31

4 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/5141dac2d69227da6c72fc6a6f5b042620387dac
Fix bug 790784: Port Websites Privacy Policy

https://github.com/mozilla/bedrock/commit/0f908d9ba3cc846b89922c303eae4b739534a62e
Merge pull request #933 from openjck/790784-websites-privacy

Fix bug 790784: Port Websites Privacy Policy

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
fixed on stage https://www.allizom.org/en-US/privacy/policies/websites/
verified fixed http://www.mozilla.org/en-US/privacy/policies/websites/
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.