Closed Bug 790966 Opened 7 years ago Closed 5 years ago

Multiple repaints more expensive with gfx.content.azure.enabled=true (was: Tab animations slower with gfx.content.azure.enabled=true)

Categories

(Core :: Graphics, defect)

17 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

VERIFIED INVALID

People

(Reporter: marco, Unassigned)

References

(Depends on 1 open bug)

Details

Enabling Azure for content slows down tab animations.

The weird thing is that FX_TAB_ANIM_CLOSE_MS and FX_TAB_ANIM_OPEN_MS are similar (~300ms with or without the option set). But the animation with the option set to true is noticeably slower (mainly the opacity transition).
Blocks: 715768
Blocks: 593680
Component: Tabbed Browser → Graphics
Product: Firefox → Core
Whiteboard: [Snappy]
I figured out this problem occurs only if browser.newtab.preload=true.
See Also: → 786484
With browser.newtab.preload=true, FX_TAB_ANIM_CLOSE_MS is ~30ms longer with gfx.content.azure.enabled=true than with gfx.content.azure.enabled=false.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 786484
Isn't the difference between gfx.content.azure.enabled=true and gfx.content.azure.enabled=false worth investigating?
(In reply to Marco Castelluccio [:marco] from comment #4)
> Isn't the difference between gfx.content.azure.enabled=true and
> gfx.content.azure.enabled=false worth investigating?

Yeah, sorry, I think it might be worth investigating why excessive invalidation is more expensive with Azure enabled.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Summary: Tab animations slower with gfx.content.azure.enabled=true → Multiple repaints more expensive with gfx.content.azure.enabled=true (was: Tab animations slower with gfx.content.azure.enabled=true)
No longer blocks: 593680
I think this -might- be related to bug 778367. I'm currently debugging an issue with that bug, we can try again after that.
We should retest on tomorrow's nightly which will have the fix to bug 778367
(In reply to Bas Schouten (:bas.schouten) from comment #7)
> We should retest on tomorrow's nightly which will have the fix to bug 778367

Marco, can you retest?
Whiteboard: [Snappy]
Can you still reproduce the issue with latest version with clean new fresh profile without any addons and plugins?
Flags: needinfo?(mar.castelluccio)
The configuration option doesn't seem to exist anymore, so I wouldn't know how to test this.
Status: REOPENED → RESOLVED
Closed: 7 years ago5 years ago
Flags: needinfo?(mar.castelluccio)
Resolution: --- → INVALID
FYI - Auzre is probably forced enabled now.
So if this issue is not present anymore it's good.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.