1 pixel cracks visible in some xul widgets that use background images

RESOLVED WORKSFORME

Status

()

Core
Layout
--
trivial
RESOLVED WORKSFORME
17 years ago
11 years ago

People

(Reporter: Skewer, Assigned: Alexandru Savulov)

Tracking

({modern, polish})

Trunk
Future
x86
Windows 98
modern, polish
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Procedure: Using the Modern theme, copy the below text into your URL bar
(assuming Bugzilla doesn't know well enough to make it a link):

javascript:alert(confirm("Foo"));

Expected: OK button is all in one piece.

Actual: Right side of OK button is broken off. Always reproducible with Modern
theme, does not occur with Classic theme.

Build: 20010505 Win98
(Reporter)

Updated

17 years ago
Keywords: modern

Comment 1

17 years ago
-> Themes
Assignee: ben → hewitt
Status: UNCONFIRMED → NEW
Component: Skinability → Themes
Ever confirmed: true
QA Contact: blakeross → pmac

Comment 2

17 years ago
reporter: please attach a picture, thanks.

Comment 3

17 years ago
Don't need a picture - this is a longstanding bug in layout.  My guess is, the
twips-to-pixels calculation is occasionally off by one pixel, leaving the
"crack" in the buttons where the background image is not painted.  This can also
be seen in the scrollbar thumbs in modern.
Assignee: hewitt → karnaze
Component: Themes → Layout
QA Contact: pmac → petersen
Summary: JS confirm dialog: OK button has a "crack" down one side → 1 pixel cracks visible in some xul widgets that use background images
(Reporter)

Comment 4

17 years ago
Created attachment 33420 [details]
Confirm window with broken OK button
(Reporter)

Comment 5

17 years ago
BTW, I am getting this behavior in 16 and 32 bit color 800x600 resolution, and
my desktop has 15x15 twips per pixel.

Comment 6

17 years ago
*** Bug 81445 has been marked as a duplicate of this bug. ***

Comment 7

17 years ago
*** Bug 81474 has been marked as a duplicate of this bug. ***

Comment 8

17 years ago
*** Bug 81459 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 9

17 years ago
Keywording. Should this be -> Skinability?
Keywords: nsbeta1, polish, ui
(Reporter)

Comment 10

17 years ago
Nominating for moz0.9.1
Keywords: mozilla0.9.1
(Reporter)

Comment 11

17 years ago
I haven't seen this problem in a while. Has anyone else?

Comment 12

17 years ago
yes, it's still there
(Reporter)

Comment 13

17 years ago
Where is it happening now? I may need to update the testcase.

Comment 14

17 years ago
Reassigning to savulov and moving to m0.9.3. Alex, I suspect that Hewitt's 
comments on 5/7/1 may be right. I have seen cases where blocks do not size 
frames on even pixel boundaries.
Assignee: karnaze → alexsavulov
Target Milestone: --- → mozilla0.9.3

Comment 15

17 years ago
scrollbar thumb's rounding error is bug 56876.

Comment 16

17 years ago
I see the pixel cracks in spell check on new modern on todays branch build Win32
2001-07-23-06 0.9.2. They show on the right side of the "Ignore All", "Edit" and
"Close" buttons

Comment 17

17 years ago
July23 commercial branch 0.9.2:  Search Mail/News Messages has the problem in
one of the criteria dropdowns.

Comment 18

17 years ago
On Linux 2001-07-24-05 0.9.2 Branch in New Modern, I also see this in the knock
knockdialogs  "block" button  for IM
(Assignee)

Comment 19

17 years ago
moving to 0.9.4
Target Milestone: mozilla0.9.3 → mozilla0.9.4

Comment 20

16 years ago
Where is the twips-to-pixels calculation being done?  I'd like to see if there
is some obvious error in the algorithm somewhere.

Comment 21

16 years ago
*** Bug 89426 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 22

16 years ago
pushing to 0.9.5
Target Milestone: mozilla0.9.4 → mozilla0.9.5

Comment 23

16 years ago
*** Bug 98390 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 24

16 years ago
removed target milestone
Target Milestone: mozilla0.9.5 → ---

Updated

16 years ago
Blocks: 104166

Comment 25

16 years ago
*** Bug 106367 has been marked as a duplicate of this bug. ***

Comment 26

16 years ago
Is this related to bug #80530? 
<a href="http://bugzilla.mozilla.org/show_bug.cgi?id=80530">80530</a>
(Assignee)

Comment 27

16 years ago
future
Target Milestone: --- → Future

Comment 28

15 years ago
WFM (buildID: 2002072204).
Could we close this one now ?

/jc
WFM 2002072608 on Win2k. 

Reporter: Are you still seeing this bug?
(Reporter)

Comment 30

15 years ago
See comment 11 for my experience.
WFM. Resolving so.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.