bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.

Post-persona login is laggy and sometimes appears busted

RESOLVED FIXED in 2013-04-25


Consumer Pages
6 years ago
5 years ago


(Reporter: mfinkle, Assigned: basta)




(Whiteboard: c=consumer u=user p=2)

On mobile devices, I have noticed that when signing into the Marketplace using persona, there is a lag before the marketplace moves away from it's initial "Log in / Register" page.

I assume the lag is due to persona closing it's tab (persona opens in a tab on mobile) but marketplace has not been given the sign in auth yet. The result is what appears to be a hang after persona closes.

Could we change the marketplace "Log in / Register" page to some sort of throbber or "authenticating..." mode after the "Log in/Register" button is pressed? That way we have some kind of que that a background process is underway when the page is shown again after the persona tab closes.
I can't reproduce this, is there a specific device that you're using where this happens? Or a slow internet connection?
(In reply to Ben Adida [:benadida] from comment #1)
> I can't reproduce this, is there a specific device that you're using where
> this happens? Or a slow internet connection?

Galaxy Nexus. When using a Wifi connection, things are acceptable. The pause after login where I see the Marketplace login page is very brief. Less than 1 second.

When using a 3g data connection the pause is far more noticeable, 2 to 3 secondss.
Adding Erin -- Erin, this sounds like what just happened to you today during our noon meeting? What device was your phone, and what kind of network?
Can we move this outside of the Marketplace product?
Is there an action for this bug?  Is this an Identity bug?
On the Identity side, I'm leading a small project to improve the experience on slow connections:


From the bug description, it does however sound like there might be a Marketplace-specific problem too.
I would love to see some more data, as per Francois's comment, logging in with Persona on a B2G phone on 2G is actually okay (after the initial dialog load, which Francois is specifically improving.)

Marketplace: are you seeing delays in the verifier? Somewhere else?
Does this still happen?
Whiteboard: c=consumer u=user
Last Resolved: 5 years ago
Resolution: --- → FIXED
I will keep this bug open to reduce the number of HTTP requests. An asynchronous login is the future.
Resolution: FIXED → ---
See Also: → bug 833955
Whiteboard: c=consumer u=user → c=consumer u=user p=2

Comment 10

5 years ago
Fireplace fixes this with asynchronous login.
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Assignee: nobody → mattbasta
Target Milestone: --- → 2013-04-25
You need to log in before you can comment on or make changes to this bug.