Selecting pop-out on flash causes flash to stop working on 18.0a1 on Ubuntu

RESOLVED INVALID

Status

()

RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: sarah, Unassigned)

Tracking

18 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:18.0) Gecko/18.0 Firefox/18.0
Build ID: 20120913152130

Steps to reproduce:

1) Open a video at hulu.com
2) Select Settings (cog icon in video)
3) Click Pop-out

Ubuntu 12.04 - 64-bit

FirefoxMozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20120913152130


Actual results:

Flash stopped - rest of browser continued as normal. Could not recover with a page refresh - end up with processes that won't die.


Expected results:

Video moves into pop-out separate window.
Mozilla/5.0 (X11; Linux i686; rv:18.0) Gecko/18.0 Firefox/18.0
Build ID: 20120918030553

Works fine for me on Ubuntu 12.04 - 32bit.

Could you please try to reproduce this in safe mode?
http://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
Component: Untriaged → Plug-ins
Product: Firefox → Core
(Reporter)

Comment 2

6 years ago
Hi,

Yes, I'm seeing the same in safe mode. Here is some extra information. When the flash is running there are two processes showing on my machine:
bird      5406     1 28 11:22 ?        00:00:45 /usr/lib/firefox-trunk/firefox-trunk
bird      5488  5406 24 11:22 ?        00:00:26 /usr/lib/firefox-trunk/plugin-container /usr/lib/flashplugin-installer/libflashplayer.so -greomni /usr/lib/firefox-trunk/omni.ja 5406 plugin

When I normally close, first 5488 will close and then 5406. Once I click PopOut apparently 5488 hangs because it doesn't close and leaves the two processes hanging around in the background.

I don't know if this helps, but when I do the same process on my standard Firefox (15.0.1), I see the following processes:
bird      5760     1 35 11:25 ?        00:00:26 /usr/lib/firefox/firefox
bird      5831  5760 69 11:25 ?        00:00:44 /usr/lib/firefox/plugin-container /usr/lib/flashplugin-installer/libflashplayer.so -greomni /usr/lib/firefox/omni.ja 5760 true plugin

Notice the extra "true" at the end of the line in between the pid and "plugin" - hope this helps....
(Reporter)

Comment 3

6 years ago
Hi, Some more information on this...

I am having the same problem with google chat, which also has a pop-out option. Again, I can see the difference between the process lines between 15.0.1 and nightly build is the missing "true"

Firefox 15.0.1:
bird      6646  5760  0 11:39 ?        00:00:00 /usr/lib/firefox/plugin-container /opt/google/talkplugin/libnpgoogletalk.so -greomni /usr/lib/firefox/omni.ja 5760 true plugin

Firefox nightly:
bird      6586  6544  0 11:38 ?        00:00:00 /usr/lib/firefox-trunk/plugin-container /opt/google/talkplugin/libnpgoogletalk.so -greomni /usr/lib/firefox-trunk/omni.ja 6544 plugin
(Reporter)

Comment 4

6 years ago
Hi, updated to 20120929184322 just now and the problem is now gone, so marking as resolved.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.