Intermittently hitting "Problem loading page" page

RESOLVED DUPLICATE of bug 771832

Status

()

Core
Networking: Cache
RESOLVED DUPLICATE of bug 771832
5 years ago
5 years ago

People

(Reporter: catlee, Unassigned)

Tracking

16 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
On recent nightlies, I've been having an intermittent problem when reloading pages, or going back in history. Sometimes (~5% of the time maybe), I get the "Problem loading page" page displayed, e.g. http://people.mozilla.org/~catlee/sattap/d45a4d6b.png

Reloading the page again usually works.
That looks related to bug 771832
Component: General → Networking: Cache
Product: Firefox → Core
Could you create a http log with an additional cache:5 for a page where you can reproduce the loading error ?
(Reporter)

Comment 3

5 years ago
(In reply to Matthias Versen (Matti) from comment #2)
> Could you create a http log with an additional cache:5 for a page where you
> can reproduce the loading error ?

What does that mean?
(In reply to Chris AtLee [:catlee] from comment #3)
> (In reply to Matthias Versen (Matti) from comment #2)
> > Could you create a http log with an additional cache:5 for a page where you
> > can reproduce the loading error ?
> 
> What does that mean?

See https://developer.mozilla.org/en-US/docs/HTTP_Logging.  Please also add cache:5 to the list in NSPR_LOG_MODULES.  Thanks.

Please watch bug 795897 for being fixed and also present in your installed Nightly (don't ask me how to figure that out. ;))

If you can, please save logs between sessions and send them as well (private email is probably better, send it to me directly please).

Comment 5

5 years ago
I've been hitting this bug in Aurora for the last week or so intermittently. I'll try to turn on the logging as described there.
(Reporter)

Comment 6

5 years ago
This seems to be working for me now on nightly...
in that case this is a dupe of bug 771832.
Kevin: with the fix of bug 771832 gecko will not write bad cache files anymore (or should). You could still hit the issue with recent builds because the bad cache files were written by older builds.
Clear the disk cache and create a new bug report if you still get the problem.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 771832

Comment 8

5 years ago
Can you give me more detail on time frame? Should I have been getting it as recently as yesterday in Aurora for pages I hadn't visited before (i.e. when selecting the tab after a browser restart)? Was this a new regression? I don't think I ever saw it before this week.

I've cleared my cache, so if it is actually fixed I shouldn't see it again, but it's confusing to me that I was seeing this at all since that other bug makes it look like the fix was committed to Aurora before I ever saw this.
It's all in the bug.
The checking comment for Aurora is bug 771832#c43 (2012-10-23 05:56:11 CEST ) 

With that checkin you should not get new broken cache files but you still have the old ones in your cache. It's of course possible that this isn't fixed and the issue is still there.
You need to log in before you can comment on or make changes to this bug.