[Screen Rotation] If next rotation degree is on 180 then screen didn't rotation until touching screen.

RESOLVED DUPLICATE of bug 796722

Status

Firefox OS
General
RESOLVED DUPLICATE of bug 796722
6 years ago
5 years ago

People

(Reporter: mchen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Test Procedures:
  1. Open the browser on Otoro.
  2. Keep device on 0 degree.
  3. Rotate the device to 180 degree as fast as possible.

NG result:
  Screen just keep on 0 degree.

Expected result:
  Screen rotates to 180 degree.

More Info:
  I verified that OrientationObserver indeed call setRotation API to notify next rotation.
  So it seems be not the bug on HAL but I didn't know the precise category.

Updated

6 years ago
Component: Hardware Abstraction Layer (HAL) → General
Product: Core → Boot2Gecko

Comment 1

6 years ago
sounds like a gaia bug
so I also file this on https://github.com/mozilla-b2g/gaia/issues/5118
Can someone check this?
(Reporter)

Comment 2

5 years ago
This is still happened on current b2g-18 build.

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 796722
You need to log in before you can comment on or make changes to this bug.