Last Comment Bug 791218 - Add "MetroFirefox" product to Socorro
: Add "MetroFirefox" product to Socorro
Status: VERIFIED FIXED
metro-preview
:
Product: Socorro
Classification: Server Software
Component: Webapp (show other bugs)
: unspecified
: x86_64 Windows 8.1
: -- normal (vote)
: 35
Assigned To: Robert Helmer [:rhelmer]
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-14 05:49 PDT by Jim Mathies [:jimm]
Modified: 2014-07-24 11:06 PDT (History)
10 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Jim Mathies [:jimm] 2012-09-14 05:49:34 PDT
The win8 version of firefox for the metro immersive environment is a separate browser from the desktop product and as such has it's own app id and app name. Filing this bug to be sure crash reports (currently triggered in elm builds) are accessible via crash stats. It would also be nice if we could filter on the 'MetroFirefox' product name through the main interface.

Here's an example crash report I generated - 

https://crash-stats.mozilla.com/report/index/bp-d58d5407-f8f0-465c-9d80-94e892120914

The app id is {99bceaaa-e3c6-48c1-b981-ef9b46b67d60}
Comment 1 Scoobidiver (away) 2012-09-14 06:37:03 PDT
Metro is a trademark of Metro AG and Microsoft chose to no longer use it: http://news.cnet.com/8301-10805_3-57490379-75/microsoft-dont-call-it-metro-call-it-windows-8/

The product name should be FirefoxWin8 or Win8Firefox.
Comment 2 Jim Mathies [:jimm] 2012-09-14 06:54:56 PDT
(In reply to Scoobidiver from comment #1)
> Metro is a trademark of Metro AG and Microsoft chose to no longer use it:
> http://news.cnet.com/8301-10805_3-57490379-75/microsoft-dont-call-it-metro-
> call-it-windows-8/
> 
> The product name should be FirefoxWin8 or Win8Firefox.

Externally we just call it Firefox. Internally we're using monikers like MetroFirefox, metrofx, etc.. There's no harm in this.

FWIW, any moniker we do use shouldn't be specific to Win8 since I'm pretty sure Metro will be with us through multiple Windows releases.
Comment 3 Robert Kaiser 2012-09-14 07:23:37 PDT
Hrm, I hoped it would just report as "Fennec" and then everything would have been easy as everything would have been there right away. But well, it's "MetroFirefox", so we'll go and add another product and let the old one sit there unused and get covered with dust... ;-)

So, for adding a new product, we need three sets of data:

1) Product info (could figure that out from the report you submitted):
Product Name: "MetroFirefox"
Product ID: "{99bceaaa-e3c6-48c1-b981-ef9b46b67d60}"
Special/Rewriting needs: none

2) Where on FTP does RelEng post the builds for this, so we can scrape for info on new builds/versions?

3) Do we have ADU metrics? We need to make sure those are posted to Socorro correctly by the metrics team.


jimm, can you answer those questions in #2 and #3?


And, Scoobidiver, given that this is internal names and a development-only-facing website (I include all of our stability community in "development" there), we don't need to care about official branding issues or trademarks, from what I understand.
Comment 4 Scoobidiver (away) 2012-09-14 07:46:29 PDT
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #3)
> Hrm, I hoped it would just report as "Fennec" and then everything would have
> been easy as everything would have been there right away.
Fennec 10.0.5esr (unsafe version) is still used by about 130kADU.
Comment 5 Jim Mathies [:jimm] 2012-09-14 07:49:52 PDT
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #3)
> Hrm, I hoped it would just report as "Fennec" and then everything would have
> been easy as everything would have been there right away. But well, it's
> 1) Product info (could figure that out from the report you submitted):
> Product Name: "MetroFirefox"
> Product ID: "{99bceaaa-e3c6-48c1-b981-ef9b46b67d60}"
> Special/Rewriting needs: none

All correct.

> 2) Where on FTP does RelEng post the builds for this, so we can scrape for
> info on new builds/versions?

Per bug 779902, these will be stored as elm nightlies. cc'ing bhearsum/armen to confirm.

> 3) Do we have ADU metrics? We need to make sure those are posted to Socorro
> correctly by the metrics team.

Per bug 790212, we are currently sending blocklist pings. There's an example there of the ping we send.
Comment 6 Robert Kaiser 2012-09-14 07:54:57 PDT
(In reply to Jim Mathies [:jimm] from comment #5)
> Per bug 779902, these will be stored as elm nightlies. cc'ing bhearsum/armen
> to confirm.

What we care about is 1) in which nightly/ directory those are appearing, and 2) if *in the end* those will be separate builds or the same builds as those we have for desktop Firefox, in which case we'll need to do some fake-dance the same way we are doing for WebRT.
Comment 7 Jim Mathies [:jimm] 2012-09-14 08:34:04 PDT
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #6)
> (In reply to Jim Mathies [:jimm] from comment #5)
> > Per bug 779902, these will be stored as elm nightlies. cc'ing bhearsum/armen
> > to confirm.
> 
> What we care about is 1) in which nightly/ directory those are appearing,
> and 2) if *in the end* those will be separate builds or the same builds as
> those we have for desktop Firefox, in which case we'll need to do some
> fake-dance the same way we are doing for WebRT.

1) I'd like rel-eng to confirm this but here's the current Elm win32 nightly from last night - 

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2012/09/2012-09-14-04-02-04-elm/

The metro builds should start showing up in the same location. This is what bug 779902 is all about. (bhearsum, help!)

As for 2) assume for now that metro code on elm will merge to mc this fall and will be incorporated into our normal mc/aurora/beta/release builds. If that changes over the next few months it will be widely broadcast.
Comment 8 Ben Hearsum (:bhearsum) 2012-09-14 08:39:41 PDT
(In reply to Jim Mathies [:jimm] from comment #7)
> 1) I'd like rel-eng to confirm this but here's the current Elm win32 nightly
> from last night - 
> 
> http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2012/09/2012-09-14-04-
> 02-04-elm/
> 
> The metro builds should start showing up in the same location. This is what
> bug 779902 is all about. (bhearsum, help!)

Yeah, that would be an example of a build directory they would show up in. I think Socorro folks will probably want to look at https://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-elm/ instead, though. I don't know what the file names for Metro builds will look like yet, it depends on what MOZ_PKG_PLATFORM gets set to (https://bugzilla.mozilla.org/show_bug.cgi?id=779902#c29).
Comment 9 Robert Kaiser 2012-09-14 09:46:46 PDT
AFAIK, Socorro never looks at latest-* and if the team would be forced to do that, we'd have no luck adding the product this year.

That said, for me, it looks like the FTP story mirrors what we have for WebappRuntime.

FYI, we'll not have graphs or topcrash reports in any case until you'll be on the normal "nightly" etc. channels, though, and that's also something that will not be able to change withing any reasonable timeframe.
Comment 10 Ben Hearsum (:bhearsum) 2012-09-14 09:48:27 PDT
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #9)
> AFAIK, Socorro never looks at latest-* and if the team would be forced to do
> that, we'd have no luck adding the product this year.
> 
> That said, for me, it looks like the FTP story mirrors what we have for
> WebappRuntime.
> 
> FYI, we'll not have graphs or topcrash reports in any case until you'll be
> on the normal "nightly" etc. channels, though, and that's also something
> that will not be able to change withing any reasonable timeframe.

Sorry, I didn't meant to imply that you should be looking there, I merely meant that I thought those type of directories are where you already look. If you tell me where you normally look for whatever information you need I can tell you more precisely what the Metro equivalent will be.
Comment 11 Robert Kaiser 2012-09-14 09:54:14 PDT
Rob actually knows the details, I'm just the messenger between the world and the Socorro team in most cases. ;-)

In any case, from what I see, this ends up being in /firefox/nightly/ and therefore we need to do the same trick as for WebappRuntime where we mirror what we scrape for Firefox over to this product.
Comment 13 Jim Mathies [:jimm] 2012-09-26 10:58:14 PDT
So it would be nice to get MetroFirefox in the product listing, but it's not absolutely necessary. To find a crash, you can do a similar search under Firefox, then just edit the product code in the url.
Comment 14 Robert Helmer [:rhelmer] 2012-09-26 13:51:01 PDT
(In reply to Ben Hearsum [:bhearsum] from comment #10)
> (In reply to Robert Kaiser (:kairo@mozilla.com) from comment #9)
> > AFAIK, Socorro never looks at latest-* and if the team would be forced to do
> > that, we'd have no luck adding the product this year.
> > 
> > That said, for me, it looks like the FTP story mirrors what we have for
> > WebappRuntime.
> > 
> > FYI, we'll not have graphs or topcrash reports in any case until you'll be
> > on the normal "nightly" etc. channels, though, and that's also something
> > that will not be able to change withing any reasonable timeframe.
> 
> Sorry, I didn't meant to imply that you should be looking there, I merely
> meant that I thought those type of directories are where you already look.
> If you tell me where you normally look for whatever information you need I
> can tell you more precisely what the Metro equivalent will be.

Socorro does record all nightly builds and all channels, you can see the script here:
https://github.com/mozilla/socorro/blob/master/socorro/cron/ftpscraper.py

So we should be able to show individual crashes fine.

*However* Socorro only shows reports (such as graphs, "top crashes by signature", etc) for nightly/aurora/beta/release (by design), if we need to support experimental branches we'll need to add support for that.
Comment 15 Jim Mathies [:jimm] 2012-09-26 14:21:29 PDT
Having a rudimentary top-crashes list will be important. I'm not sure how we would track what we need to work on without it. Can we generate those manually occasionally or maybe access the raw data somehow?
Comment 16 Jim Mathies [:jimm] 2012-09-26 14:22:44 PDT
This would be for elm nightly builds only, for maybe three months tops before we get everything integrated into mc.
Comment 17 Robert Kaiser 2012-09-26 14:32:38 PDT
(In reply to Robert Helmer [:rhelmer] from comment #14)
> if we need to
> support experimental branches we'll need to add support for that.

That's bug 703018.

(In reply to Jim Mathies [:jimm] from comment #15)
> Having a rudimentary top-crashes list will be important. I'm not sure how we
> would track what we need to work on without it. Can we generate those
> manually occasionally or maybe access the raw data somehow?

When we add this product, you should be able to get that via an advanced search, actually, similar to this one: https://crash-stats.mozilla.com/query/query?product=B2G&version=ALL%3AALL&do_query=1 (B2G also is not using the "correct" channels yet, for other reasons, though).
Comment 18 Robert Helmer [:rhelmer] 2013-01-09 11:17:34 PST
selena, r? https://github.com/mozilla/socorro/pull/1040
Comment 19 [github robot] 2013-01-14 10:17:11 PST
Commit pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/e03d68f589c6502fe6f9d30170fb59bdd4d0290b
bug 791218 - add metrofirefox to socorro
+ Update for v 35.0 and setting rapid beta version
Comment 20 Selena Deckelmann :selenamarie :selena use ni? 2013-01-14 10:45:14 PST
Applied DB change to dev.

[postgres@socorro1 35.0]$ ./upgrade.sh 
*********************************************************
add MetroFirefox to database
bug 791218
DO
Time: 69.647 ms
CREATE FUNCTION
Time: 26.756 ms
 update_socorro_db_version 
---------------------------
 t
(1 row)

34.0 upgrade done

Note You need to log in before you can comment on or make changes to this bug.