Get ns1{a,b}.build.mtv1.mozilla.com and SCL1 named slaves away from using mradm01

RESOLVED FIXED

Status

Infrastructure & Operations
Infrastructure: Other
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: dustin, Assigned: digi)

Tracking

Details

(Reporter)

Description

5 years ago
Per bug 798517, mradm01 was shut down yesterday.  However, from what I can tell these nameservers are still slaves to mradm01, meaning that they're not getting updates now (e.g., to mozilla.org), and that they'll stop answering next week since their data is stale.
(Assignee)

Updated

5 years ago
Assignee: server-ops-infra → bhourigan

Updated

5 years ago
Blocks: 791293
Summary: ns1{a,b}.build.mtv1.mozilla.com are slaving from the now-dead mradm01 → Get ns1{a,b}.build.mtv1.mozilla.com and SCL1 named slaves away from using mradm01

Comment 1

5 years ago
I turned mradm01 back on for now, since we'll need to do some changes to the nameservers in scl1 as well and shouldn't be done on a Friday.
(Assignee)

Comment 2

5 years ago
I've updated the configuration on ns1b.build.mtv1 to no longer depend on mradm01. After this host has been tested I'll migrate the keepalive vip from ns1a and apply the same configuration changes there.
(Reporter)

Comment 3

5 years ago
From all the tests I can see, it's giving the right results.  Turn it on!

By the way, admin1a/b.infra.scl1 are also slaves.
(Assignee)

Comment 4

5 years ago
I've applied the same changes to ns1a.build.mtv1 and temporarily disabled keepalived to prevent the vip from moving back. Once validated I'll re-enable keepalived.

I'll look into admin1[ab].infra.scl1 now
(Reporter)

Comment 5

5 years ago
ns1a lgtm
(Assignee)

Comment 6

5 years ago
Great, thanks! I've re-enabled keepalived and confirmed the vip properly migrated back to ns1a and is answering queries. I've filed 792586 to track admin1[ab].infra.scl1
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Component: Server Operations: Infrastructure → Infrastructure: Other
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.