Last Comment Bug 791305 - Use libjpeg's color conversion code instead of our own.
: Use libjpeg's color conversion code instead of our own.
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: ImageLib (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal with 1 vote (vote)
: mozilla18
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks: 584652 803914
  Show dependency treegraph
 
Reported: 2012-09-14 10:49 PDT by Jeff Muizelaar [:jrmuizel]
Modified: 2012-10-20 15:34 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Use libjpeg's color conversion code instead of our own. (20.67 KB, patch)
2012-09-14 10:49 PDT, Jeff Muizelaar [:jrmuizel]
no flags Details | Diff | Review
v2 (20.94 KB, patch)
2012-09-14 12:04 PDT, Jeff Muizelaar [:jrmuizel]
joe: review+
khuey: review+
Details | Diff | Review

Description Jeff Muizelaar [:jrmuizel] 2012-09-14 10:49:10 PDT
Created attachment 661278 [details] [diff] [review]
Use libjpeg's color conversion code instead of our own.

This will be faster because we'll get to use sse2 for color conversion and I was seeing ycc_rgb_convert_argb show up in profiles.
Comment 1 Jeff Muizelaar [:jrmuizel] 2012-09-14 12:04:07 PDT
Created attachment 661305 [details] [diff] [review]
v2
Comment 2 Joe Drew (not getting mail) 2012-09-14 12:12:49 PDT
Comment on attachment 661305 [details] [diff] [review]
v2

Review of attachment 661305 [details] [diff] [review]:
-----------------------------------------------------------------

r=me, but need review for configure.in change to force use of jpeg-turbo
Comment 3 Ryan VanderMeulen [:RyanVM] 2012-09-14 18:16:59 PDT
https://hg.mozilla.org/mozilla-central/rev/63900a754a53

Note You need to log in before you can comment on or make changes to this bug.