(Intermittent) Cannot load DOMApplicationRegistry, homescreen apps won't load after installing, launching, and uninstalling an untrusted packaged app and restarting the phone

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: jsmith, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 661386 [details]
Logcat

Build:

* Device: Otoro
* Mozilla Central: f415ee0ecf8829b6cb37659a80b1780acd64c41c
* Gaia: bc3eacff55cd46ac307e3c251760d2c21fb9c75b

Issue:

I've currently ended up in a state with my phone where the apps and their associated icons will not load on the homescreen. The only things I've done prior to this was installing a couple of apps with "type" piece of the manifest used and made use of the browser to install those apps. If I restart my phone, the problem isn't fixed. Hopefully the logcat will give some details on what's going on.
(Reporter)

Comment 1

6 years ago
One snippet that looks problematic:

09-14 22:11:28.895: E/GeckoConsole(106): [JavaScript Error: "DOMApplicationRegistry: Could not read from /data/local/webapps/calculator.thisdomaindoesnotexist.org/manifest.json : [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIChannel.asyncOpen]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: resource://gre/modules/NetUtil.jsm :: NetUtil_asyncOpen :: line 165"  data: no]" {file: "resource://gre/modules/Webapps.jsm" line: 297}]
09-14 22:11:28.905: E/GeckoConsole(106): [JavaScript Error: "DOMApplicationRegistry: Could not read from /data/local/webapps/browser.thisdomaindoesnotexist.org/manifest.json : [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIChannel.asyncOpen]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: resource://gre/modules/NetUtil.jsm :: NetUtil_asyncOpen :: line 165"  data: no]" {file: "resource://gre/modules/Webapps.jsm" line: 297}]
09-14 22:11:28.925: E/GeckoConsole(106): [JavaScript Error: "DOMApplicationRegistry: Could not read from /data/local/webapps/costcontrol.thisdomaindoesnotexist.org/manifest.json : [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIChannel.asyncOpen]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: resource://gre/modules/NetUtil.jsm :: NetUtil_asyncOpen :: line 165"  data: no]" {file: "resource://gre/modules/Webapps.jsm" line: 297}]
09-14 22:11:28.925: E/GeckoConsole(106): [JavaScript Error: "DOMApplicationRegistry: Could not read from /data/local/webapps/fm.thisdomaindoesnotexist.org/manifest.json : [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIChannel.asyncOpen]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: resource://gre/modules/NetUtil.jsm :: NetUtil_asyncOpen :: line 165"  data: no]" {file: "resource://gre/modules/Webapps.jsm" line: 297}]
09-14 22:11:28.935: E/GeckoConsole(106): [JavaScript Error: "DOMApplicationRegistry: Could not read from /data/local/webapps/homescreen.thisdomaindoesnotexist.org/manifest.json : [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIChannel.asyncOpen]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: resource://gre/modules/NetUtil.jsm :: NetUtil_asyncOpen :: line 165"  data: no]" {file: "resource://gre/modules/Webapps.jsm" line: 297}]
09-14 22:11:28.955: E/GeckoConsole(106): [JavaScript Error: "DOMApplicationRegistry: Could not read from /data/local/webapps/settings.thisdomaindoesnotexist.org/manifest.json : [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIChannel.asyncOpen]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: resource://gre/modules/NetUtil.jsm :: NetUtil_asyncOpen :: line 165"  data: no]" {file: "resource://gre/modules/Webapps.jsm" line: 297}]
09-14 22:11:28.975: E/GeckoConsole(106): [JavaScript Error: "DOMApplicationRegistry: Could not read from /data/local/webapps/gallery.thisdomaindoesnotexist.org/manifest.json : [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIChannel.asyncOpen]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: resource://gre/modules/NetUtil.jsm :: NetUtil_asyncOpen :: line 165"  data: no]" {file: "resource://gre/modules/Webapps.jsm" line: 297}]
09-14 22:11:28.985: E/GeckoConsole(106): [JavaScript Error: "DOMApplicationRegistry: Could not read from /data/local/webapps/system.thisdomaindoesnotexist.org/manifest.json : [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIChannel.asyncOpen]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: resource://gre/modules/NetUtil.jsm :: NetUtil_asyncOpen :: line 165"  data: no]" {file: "resource://gre/modules/Webapps.jsm" line: 297}]
09-14 22:11:29.015: E/GeckoConsole(106): [JavaScript Error: "DOMApplicationRegistry: Could not read from /data/local/webapps/email.thisdomaindoesnotexist.org/manifest.json : [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIChannel.asyncOpen]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: resource://gre/modules/NetUtil.jsm :: NetUtil_asyncOpen :: line 165"  data: no]" {file: "resource://gre/modules/Webapps.jsm" line: 297}]
09-14 22:11:29.025: E/GeckoConsole(106): [JavaScript Error: "DOMApplicationRegistry: Could not read from /data/local/webapps/clock.thisdomaindoesnotexist.org/manifest.json : [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIChannel.asyncOpen]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: resource://gre/modules/NetUtil.jsm :: NetUtil_asyncOpen :: line 165"  data: no]" {file: "resource://gre/modules/Webapps.jsm" line: 297}]
09-14 22:11:29.035: E/GeckoConsole(106): [JavaScript Error: "DOMApplicationRegistry: Could not read from /data/local/webapps/camera.thisdomaindoesnotexist.org/manifest.json : [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIChannel.asyncOpen]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: resource://gre/modules/NetUtil.jsm :: NetUtil_asyncOpen :: line 165"  data: no]" {file: "resource://gre/modules/Webapps.jsm" line: 297}]
09-14 22:11:29.045: E/GeckoConsole(106): [JavaScript Error: "DOMApplicationRegistry: Could not read from /data/local/webapps/communications.thisdomaindoesnotexist.org/manifest.json : [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIChannel.asyncOpen]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: resource://gre/modules/NetUtil.jsm :: NetUtil_asyncOpen :: line 165"  data: no]" {file: "resource://gre/modules/Webapps.jsm" line: 297}]
09-14 22:11:29.055: E/GeckoConsole(106): [JavaScript Error: "DOMApplicationRegistry: Could not read from /data/local/webapps/calendar.thisdomaindoesnotexist.org/manifest.json : [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIChannel.asyncOpen]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: resource://gre/modules/NetUtil.jsm :: NetUtil_asyncOpen :: line 165"  data: no]" {file: "resource://gre/modules/Webapps.jsm" line: 297}]
09-14 22:11:29.065: E/GeckoConsole(106): [JavaScript Error: "DOMApplicationRegistry: Could not read from /data/local/webapps/video.thisdomaindoesnotexist.org/manifest.json : [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIChannel.asyncOpen]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: resource://gre/modules/NetUtil.jsm :: NetUtil_asyncOpen :: line 165"  data: no]" {file: "resource://gre/modules/Webapps.jsm" line: 297}]
09-14 22:11:29.075: E/GeckoConsole(106): [JavaScript Error: "DOMApplicationRegistry: Could not read from /data/local/webapps/music.thisdomaindoesnotexist.org/manifest.json : [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIChannel.asyncOpen]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: resource://gre/modules/NetUtil.jsm :: NetUtil_asyncOpen :: line 165"  data: no]" {file: "resource://gre/modules/Webapps.jsm" line: 297}]
09-14 22:11:29.085: E/GeckoConsole(106): [JavaScript Error: "DOMApplicationRegistry: Could not read from /data/local/webapps/pdfjs.thisdomaindoesnotexist.org/manifest.json : [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIChannel.asyncOpen]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: resource://gre/modules/NetUtil.jsm :: NetUtil_asyncOpen :: line 165"  data: no]" {file: "resource://gre/modules/Webapps.jsm" line: 297}]
09-14 22:11:29.095: E/GeckoConsole(106): [JavaScript Error: "DOMApplicationRegistry: Could not read from /data/local/webapps/keyboard.thisdomaindoesnotexist.org/manifest.json : [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIChannel.asyncOpen]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: resource://gre/modules/NetUtil.jsm :: NetUtil_asyncOpen :: line 165"  data: no]" {file: "resource://gre/modules/Webapps.jsm" line: 297}]
09-14 22:11:29.105: E/GeckoConsole(106): [JavaScript Error: "DOMApplicationRegistry: Could not read from /data/local/webapps/sms.thisdomaindoesnotexist.org/manifest.json : [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIChannel.asyncOpen]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: resource://gre/modules/NetUtil.jsm :: NetUtil_asyncOpen :: line 165"  data: no]" {file: "resource://gre/modules/Webapps.jsm" line: 297}]
09-14 22:11:29.115: E/GeckoConsole(106): [JavaScript Error: "DOMApplicationRegistry: Could not read from /data/local/webapps/marketplace/manifest.json : [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIChannel.asyncOpen]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: resource://gre/modules/NetUtil.jsm :: NetUtil_asyncOpen :: line 165"  data: no]" {file: "resource://gre/modules/Webapps.jsm" line: 297}]
09-14 22:11:29.125: E/GeckoConsole(106): [JavaScript Error: "DOMApplicationRegistry: Could not read from /data/local/webapps/marketplace-dev/manifest.json : [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIChannel.asyncOpen]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: resource://gre/modules/NetUtil.jsm :: NetUtil_asyncOpen :: line 165"  data: no]" {file: "resource://gre/modules/Webapps.jsm" line: 297}]
09-14 22:11:29.135: E/GeckoConsole(106): [JavaScript Error: "DOMApplicationRegistry: Could not read from /data/local/webapps/maps/manifest.json : [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIChannel.asyncOpen]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: resource://gre/modules/NetUtil.jsm :: NetUtil_asyncOpen :: line 165"  data: no]" {file: "resource://gre/modules/Webapps.jsm" line: 297}]
09-14 22:11:29.145: E/GeckoConsole(106): [JavaScript Error: "DOMApplicationRegistry: Could not read from /data/local/webapps/marketplace-staging/manifest.json : [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIChannel.asyncOpen]"  nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame :: resource://gre/modules/NetUtil.jsm :: NetUtil_asyncOpen :: line 165"  data: no]" {file: "resource://gre/modules/Webapps.jsm" line: 297}]
09-14 22:11:29.145: E/GeckoConsole(106): [JavaScript Error: "DOMApplicationRegistry: Could not parse JSON: TypeError: manifest is null" {file: "resource://gre/modules/Webapps.jsm" line: 290}]
(Reporter)

Comment 2

6 years ago
This is a particularly scary scenario to end up in if the phone's homescreen stops loading. I'm noming for now, but will try to get more details soon on:

- Frequency of occurrence
- Reproducibility
blocking-basecamp: --- → ?
(Reporter)

Comment 3

6 years ago
Krupa apparently hit this issue as well with her Otoro phone upon an immediate flashing of the build.
What I really need are reliable STR here, since that looks really bad.
(Reporter)

Comment 5

6 years ago
Okay. I'll start digging...
Keywords: qawanted
QA Contact: jsmith
(Reporter)

Updated

6 years ago
Keywords: steps-wanted
(Reporter)

Comment 6

6 years ago
The error Krupa got appears to be different than the one I've got, as I'm seeing the following in the logcat of both phones she has:

09-14 23:09:37.296: E/GeckoConsole(499): [JavaScript Error: "TypeError: this._listItems is not a function" {file: "app://system.gaiamobile.org/js/activities.js" line: 30}]

I'll file a separate bug on that.
(Reporter)

Comment 7

6 years ago
(In reply to Jason Smith [:jsmith] from comment #6)
> The error Krupa got appears to be different than the one I've got, as I'm
> seeing the following in the logcat of both phones she has:
> 
> 09-14 23:09:37.296: E/GeckoConsole(499): [JavaScript Error: "TypeError:
> this._listItems is not a function" {file:
> "app://system.gaiamobile.org/js/activities.js" line: 30}]
> 
> I'll file a separate bug on that.

Looks like Vivien may have already fixed that bug in https://github.com/mozilla-b2g/gaia/commit/18f92a836422bcc7ebf27bb7c13c4fcbe25f8ec9 possibly.
(Reporter)

Comment 8

6 years ago
Good news - I got it to reproduce again on my phone. Going to see if this is a reliable STR, but here's what I did:

1. Flashed the device with the 9/14 build
2. Went to http://people.rit.edu/~jds2501/downloads/appinstall.html in the browser
3. Select Install Package
4. Launch the installed package
5. Uninstalled the installed package
6. Restarted the phone

Result - Same error seen in the logcat in this bug and homescreen fails to show any app icons

Hopefully this is a reliable STR...will try it again for good measure.
(Reporter)

Comment 9

6 years ago
Looks like my STR in comment 8 worked when I tried them again from a fresh build against the mozilla-g wifi. Fabrice - Are you able to reproduce this bug with the STR from comment 8?
Keywords: qawanted, steps-wanted
(Reporter)

Updated

6 years ago
Summary: Intermittent failure after a restart and installing app type apps - Cannot load DOMApplicationRegistry, homescreen apps won't load → Cannot load DOMApplicationRegistry, homescreen apps won't load after installing, launching, and uninstalling an untrusted packaged app and restarting the phone
Jason,

I used the STR from comment 8 on a custom build (patches for bug 777204 and bug 787439 applied) and could not reproduce that.
(Reporter)

Comment 11

6 years ago
(In reply to Fabrice Desré [:fabrice] from comment #10)
> Jason,
> 
> I used the STR from comment 8 on a custom build (patches for bug 777204 and
> bug 787439 applied) and could not reproduce that.

My phone is acting up in all sorts of weird ways right now in general. I'm wondering if I got my phone into some sort of "bad state." I'll unnom for now, but keep a look out on this.
blocking-basecamp: ? → ---
(Reporter)

Updated

6 years ago
Summary: Cannot load DOMApplicationRegistry, homescreen apps won't load after installing, launching, and uninstalling an untrusted packaged app and restarting the phone → (Intermittent) Cannot load DOMApplicationRegistry, homescreen apps won't load after installing, launching, and uninstalling an untrusted packaged app and restarting the phone
(Reporter)

Comment 12

6 years ago
I'm going to close this for now as I can no longer reproduce. If I get a consistent reproduction, I'll refile.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Updated

6 years ago
Resolution: INCOMPLETE → WORKSFORME
You need to log in before you can comment on or make changes to this bug.