If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Super laggy scrolling on website

NEW
Unassigned

Status

()

Core
Graphics
5 years ago
5 years ago

People

(Reporter: jdm, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
On http://www.theochevalier.fr/, I see horrendously laggy scrolling compared to the majority of the rest of the web that I visit.
(Reporter)

Updated

5 years ago
Whiteboard: [Snappy] → [Snappy] [needs profiliing]
(Reporter)

Comment 1

5 years ago
http://people.mozilla.com/~bgirard/cleopatra/?report=f96ea97babfa36f264f186223a3c693bc74c8b23

The profile shows a killer combination of gradients and box shadows.
Component: General → Graphics
Whiteboard: [Snappy] [needs profiliing] → [Snappy]

Comment 2

5 years ago
Seems fast here. Maybe bas fixed something. Is it still slow for you?
Whiteboard: [Snappy]
(Reporter)

Comment 3

5 years ago
I don't think it's as bad as it used to be, but I still see exceedingly chopping upwards scrolling on my 10.6.8 OS X nightly.
(Reporter)

Comment 4

5 years ago
Yay, a huge percentage is some raw address: http://people.mozilla.com/~bgirard/cleopatra/#report=57f8ec4fad73fd783b71a83fc4995bcc1e618e07&selection=%255B%2522start%2522%252C%2522main%2522%252C%2522XRE_main%2522%252C%2522Startup%253A%253AXRE_Main%2522%252C%2522XREMain%253A%253AXRE_main%28int%252C%2520char**%252C%2520nsXREAppData%2520const*%29%2522%252C%2522XREMain%253A%253AXRE_mainRun%28%29%2522%252C%2522nsAppStartup%253A%253ARun%28%29%2522%252C%2522nsAppShell%253A%253ARun%28%29%2522%252C%2522-%255BNSApplication%2520run%255D%2522%252C%2522-%255BGeckoNSApplication%2520nextEventMatchingMask%253AuntilDate%253AinMode%253Adequeue%253A%255D%2522%252C%2522-%255BNSApplication%2520nextEventMatchingMask%253AuntilDate%253AinMode%253Adequeue%253A%255D%2522%252C%2522_DPSNextEvent%2522%252C%2522BlockUntilNextEventMatchingListInMode%2522%252C%2522ReceiveNextEventCommon%2522%252C%2522RunCurrentEventLoopInMode%2522%252C%2522CFRunLoopRunSpecific%2522%252C%2522__CFRunLoopRun%2522%252C%25220x7fff85a3dd7a%2522%255D
Looks like your profile can't be symbolicated. Poke me and I'll take a look.

That address is us calling into mach waiting for events. I can tell from the parent. It's idle time.
You need to log in before you can comment on or make changes to this bug.