Over saturated colors on wide gamut displa at "gfx.color_management.mode" default value 2

RESOLVED DUPLICATE of bug 455077

Status

()

Core
GFX: Color Management
--
major
RESOLVED DUPLICATE of bug 455077
5 years ago
4 years ago

People

(Reporter: auxx, Unassigned)

Tracking

15 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0.1
Build ID: 20120905151427

Steps to reproduce:

Im using a profesional wide gamut display. NEC 2690Wuxi.





Actual results:

Websites and pictures without color profile are over saturated and has magenta cast.
I found out, switching gfx.color_management.mode devault value (2) to 1, will fix the problem. 
Now all web sites looks normal in color and jpgs, with or without profile
are correctly interpreted as sRGB, as it should be.





Expected results:

The devault "gfx.color_management.mode" should be set to 1.
On "mode 1" all should be displaying correctly on wide gamut displays and
sRGB displays.
So, why is FireFox set to mode 2 by default?
(Reporter)

Updated

5 years ago
Severity: normal → major
Component: Untriaged → GFX: Color Management
Product: Firefox → Core
As for comment 1 I'll close this as dupe.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 455077
You need to log in before you can comment on or make changes to this bug.