Fix graphs to include "unknown" OS totals

RESOLVED WONTFIX

Status

Socorro
Database
RESOLVED WONTFIX
6 years ago
a year ago

People

(Reporter: jberkus, Unassigned)

Tracking

unspecified
Future
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
While troubleshooting bug 790844, I discovered that "Unknown" OS crashes are not being included in any view which depends on ADU, such as the various graphs.  This is because most of the database has these crashes as "Unknown" OS, but the ADU data uses the term "Other".

I need to add a matching column so that the Other ADU gets counted, and the Unknown OS crashes contribute to the graphs.

Note that this is NOT a regression; we have never counted the Unknown OS crashes before.  I'd just wanted them to be properly accounted in Mobeta, espeically since they account for about 7% of crashes overall.
(Reporter)

Updated

6 years ago
Target Milestone: --- → 21

Comment 1

6 years ago
I like the term "Other" better there as I heavily suspect that in most cases the OS is actually known, just not one of those we do count - and even the ones where it's really unknown (probably empty in terms of crash reports) do logically fit quite nicely under "Other".
(Reporter)

Comment 2

6 years ago
Kairo,

Changing the name used in the database in general would be several hours of code and backfilling.  Are you proposing this?

I chose the name "unknown" because a most of the time, the os_name field is simply garbage or unreadable (there is a high correlation between Unknown OS and Missing Signature).  The number of known OSes we have which are not one of the Big Three (e.g. Solaris, BSD) is a small minority.
(Reporter)

Comment 3

6 years ago
Hmmm.

Actually, per the above, I'm not sure that it's correct to match up Unknown in the crash data with Other in the ADUs.  As I said, Unknown usually indicates garbage OS data, NOT some 4th OS which is defined.  I'm pretty sure that Other in the ADU data is referring specifically to other, known OSes.  Daniel?

Comment 4

6 years ago
OK, sorry, I thought you would do a rename to match in pone way or the other here anyhow.
As you say, I also guess that this "unknown" doesn't even match "other" directly, because of the fact that I suspected and you just confirmed that most of those have missing OS fields, which means that the vast majority of those are probably actually Windows reports (not just because that's OS with the majority of reports all in all but because due to how Breakpad works the chance to get empty minidump and therefore missing OS fields is higher on Windows than on all other OSes).
(Reporter)

Comment 5

6 years ago
Yeah, we'll need to hash out how to count these later.

I'm not happy continuing to just leave them out, since they do account for around 7% of all crashes, and are far from evenly distributed.

Maybe we should distinguish between Unknown and Other.  And compare the Unknown ones against the Windows ADU.  Not sure ...
(Reporter)

Comment 6

6 years ago
Bumping to 23 because we don't have a clear spec for this.
Target Milestone: 21 → 22
(Reporter)

Updated

6 years ago
Assignee: josh → sdeckelmann
Target Milestone: 22 → 23
This will need a change on the UI side as well right?
Pinged :kairo about this -- this bug can't be addressed until definitions for "Unknown" and "Other" are made consistent between ADU and socorro.

Comment 9

6 years ago
Well, this is a tough one for sure.

It does not make sense to feature it as a separate column/checkbox as "Unknown OS" (on the crash side) and "Other OS" (on the ADU side) are different things, even though the way we do "Unknown" on the crash side, it's a strict superset to what gets put into "Other" for ADU. We do include those where we actually don't have the OS information, though, which includes all those crashes with a null minidump (I expect that to mostly happen in Windows, FWIW).

OTOH, we *really* want to be able to get total numbers across *all* OSes out of the /daily page as well (I'd argue that this should be the default) where "Unknown" and "Other are both included and summed up with the ones explicitly named in the UI. That happens to result in really relevant numbers, probably even the most relevant ones to us.

What we could do is have an additional entry at the start of that set of checkboxes, with a label of "All", and when that is checked, we disable the other three (while marking them checked, probably) and ask the middleware for the total number, like we do for the front page chart as well.
(In reply to Schalk Neethling [:espressive] from comment #7)
> This will need a change on the UI side as well right?

Yes, I think KaiRo's suggestion about the '[x] All' checkbox being added seems good in comment #9.
Target Milestone: 23 → Future

Comment 11

6 years ago
Will it fix the graph per builddate being null for Android signatures now that Linux has been replaced by Android in the OS field? See https://crash-stats.mozilla.com/report/list?signature=java.lang.NullPointerException%3A%20at%20org.mozilla.gecko.Tabs.loadUrlInTab%28Tabs.java%29#graph

Comment 12

6 years ago
(In reply to Scoobidiver from comment #11)
> Will it fix the graph per builddate being null for Android signatures now
> that Linux has been replaced by Android in the OS field?

That's a completely different problem, which I though we had fully fixed in bug 795349.

Also, the bug here is not at all about /report/list, only about /daily.
Assignee: sdeckelmann → nobody
Status: ASSIGNED → NEW

Comment 13

a year ago
nah
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.