Session Restore is not available \ not working properly

RESOLVED INVALID

Status

()

RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: khalid.ame, Unassigned)

Tracking

15 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0.1
Build ID: 20120905151427

Steps to reproduce:

1-Close firefox with a couple of tabs open
2-Open an html file with firefox or click a link on a document (ex. pdf) when firefox is default browser 
3-Firefox will open with one tab only containing the webpage \ html file



Actual results:

The session was lost


Expected results:

When opening a webpage or a link when firefox is the default browser the session restore tab should be opened in addition to the webpage
It depends on the settings you have for browser startup. If you option is to "Show my homepage" or "Show a blank page", only one tab with the html file is opened, but you can still restore your previous sessio from "about:home" page or from browser menu History>Restore Previous Session.
If the startup option is "Show my windows and tabs from last time" the browser should open the html file and the tabs from last time.
Is this the behavior you see?

Thank you!
Component: Untriaged → General

Comment 2

6 years ago
This is not a bug, it's by design. Khalid, when the webpage opens at step 3, go to the History menu. You will find the Restore Previous Session option there - you can restore your previous session by selecting this.

Works on the 10/15 Nightly.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.