text field disables after attempting to paste into it

VERIFIED INVALID

Status

()

Core
XUL
--
major
VERIFIED INVALID
17 years ago
17 years ago

People

(Reporter: Chris Waterson, Assigned: Peter Trudelle)

Tracking

({regression})

Trunk
x86
Windows 2000
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Summary: cannot paste into a text field from the clipboard, and worse, 
attempting to do so makes it so that the text field will no longer accept focus.

To reproduce:

1. Start mozilla, visit a web page with text fields (e.g., Bugzilla's
   ``Enter Bug'' page).

2. Get some text into your clipboard; e.g., by selecting the text from the
   URL bar and pressing ``Ctrl+C''

3. Set focus into a text field; e.g., the bugzilla ``URL'' field.

4. Press Ctrl+V to paste the text

Expected: text appears in the text field.
Actual: no text appears, text field no longer accepts keyboard focus.
(Reporter)

Updated

17 years ago
Keywords: regression

Comment 1

17 years ago
WorksForMe on 2001050704 (Windows 2000)

Comment 2

17 years ago
The textfields in the pref windows (XUL) do have the same sort of problems.

1. open the Navigator pref panel and click in the textfield for 'Location'.
2. click on Advanced, in order to remove the focus fomr the textfield.
3. click on Navigator again and try to focus the textfield.

Result, nada noppes niente nothing nichts

(Reporter)

Comment 3

17 years ago
Oh, I'm an idjut. This is due to some changes I have in my tree.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 4

17 years ago
Poor guy can't even spell 'idiot'. So sad ...

(Sidenote: the other behaviour mentioned in this bug, for textfields in 
preferences panels is bug 70742).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.