Closed Bug 791640 Opened 7 years ago Closed 7 years ago

Event tracer freezes Fennec

Categories

(Core :: Gecko Profiler, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: glandium, Assigned: BenWa)

References

Details

Attachments

(1 file)

This was first spotted when enabling the SPS profiler on Fennec: Fennec would freeze when trying to use the awesomebar. It turns out this is reproducible without enabling the SPS profiler at all, but by enabling the Event tracer alone.

STR:
- Start fennec with: am start -a android.activity.MAIN -n org.mozilla.fennec/.App --es env0 MOZ_INSTRUMENT_EVENT_LOOP=1
- Tap the url bar
- If it doesn't freeze straight away, try switching between Top sites/Bookmarks/History
- If it still doesn't freeze, try opening a web site and repeat the steps from "Tap the url bar".

On my nexus S, it happens sometimes the first time the url bar is tapped, if it doesn't happen then, it happens all the time after having opened an web site.
Here's the state of the main dalvik thread when deadlock:

"main" prio=5 tid=1 WAIT
  | group="main" sCount=1 dsCount=0 obj=0x40a47460 self=0xbc8828
  | sysTid=13769 nice=0 sched=0/0 cgrp=default handle=1074308232
  | schedstat=( 0 0 0 ) utm=302 stm=87 core=1
  at java.lang.Object.wait(Native Method)
  - waiting on <0x40a47530> (a java.lang.VMThread) held by tid=1 (main)
  at java.lang.Thread.parkFor(Thread.java:1231)
  at sun.misc.Unsafe.park(Unsafe.java:323)
  at java.util.concurrent.locks.LockSupport.park(LockSupport.java:157)
  at java.util.concurrent.locks.AbstractQueuedSynchronizer.parkAndCheckInterrupt(AbstractQueuedSynchronizer.java:813)
  at java.util.concurrent.locks.AbstractQueuedSynchronizer.doAcquireSharedInterruptibly(AbstractQueuedSynchronizer.java:973)
  at java.util.concurrent.locks.AbstractQueuedSynchronizer.acquireSharedInterruptibly(AbstractQueuedSynchronizer.java:1282)
  at java.util.concurrent.CountDownLatch.await(CountDownLatch.java:207)
  at org.mozilla.gecko.GeckoAppShell.geckoEventSync(GeckoAppShell.java:610)
  at org.mozilla.gecko.GeckoAppShell.sendEventToGeckoSync(GeckoAppShell.java:567)
  at org.mozilla.gecko.gfx.GeckoLayerClient.compositionPauseRequested(GeckoLayerClient.java:567)
  at org.mozilla.gecko.gfx.LayerView.onDestroyed(LayerView.java:320)
  at org.mozilla.gecko.gfx.LayerView.access$300(LayerView.java:44)
  at org.mozilla.gecko.gfx.LayerView$SurfaceListener.surfaceDestroyed(LayerView.java:361)
  at android.view.SurfaceView.updateWindow(SurfaceView.java:517)
  at android.view.SurfaceView.onWindowVisibilityChanged(SurfaceView.java:226)
  at android.view.View.dispatchWindowVisibilityChanged(View.java:5839)
  at android.view.ViewGroup.dispatchWindowVisibilityChanged(ViewGroup.java:945)
  at android.view.ViewGroup.dispatchWindowVisibilityChanged(ViewGroup.java:945)
  at android.view.ViewGroup.dispatchWindowVisibilityChanged(ViewGroup.java:945)
  at android.view.ViewGroup.dispatchWindowVisibilityChanged(ViewGroup.java:945)
  at android.view.ViewGroup.dispatchWindowVisibilityChanged(ViewGroup.java:945)
  at android.view.ViewGroup.dispatchWindowVisibilityChanged(ViewGroup.java:945)
  at android.view.ViewGroup.dispatchWindowVisibilityChanged(ViewGroup.java:945)
  at android.view.ViewRootImpl.performTraversals(ViewRootImpl.java:965)
  at android.view.ViewRootImpl.handleMessage(ViewRootImpl.java:2442)
  at android.os.Handler.dispatchMessage(Handler.java:99)
  at android.os.Looper.loop(Looper.java:137)
  at android.app.ActivityThread.main(ActivityThread.java:4424)
  at java.lang.reflect.Method.invokeNative(Native Method)
  at java.lang.reflect.Method.invoke(Method.java:511)
  at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:784)
  at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:551)
  at dalvik.system.NativeStart.main(Native Method)
Duplicate of this bug: 773308
Assignee: nobody → bgirard
Status: NEW → ASSIGNED
Attachment #663115 - Flags: review?(blassey.bugs)
Attachment #663115 - Flags: review?(blassey.bugs) → review+
https://hg.mozilla.org/mozilla-central/rev/7adfb6640886
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: Firefox 16 → Firefox 18
Component: General → Gecko Profiler
Product: Fennec Graveyard → Core
Target Milestone: Firefox 18 → ---
You need to log in before you can comment on or make changes to this bug.