bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Attempting to install on Bugzilla 3.2.4

RESOLVED INVALID

Status

Testopia
General
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: Jacob Davenport, Assigned: Greg Hendricks)

Tracking

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:15.0) Gecko/20100101 Firefox/15.0.1
Build ID: 20120905151427

Steps to reproduce:

1.  Installed the files from the testopia-2.4-BUGZILLA-3.6.tar file in my Bugzilla 3.2.4 area.

2.  Since my Bugzilla is heavily modified (which is why I haven't upgraded it) I manually patched the files.  Not a problem.

3.  I ran checksetup.pl without errors.


Actual results:

The tr_products and other Testopia tables were not created, so my patched programs that referred to that and other tables failed.


Expected results:

Maybe Bugzilla 3.2.4 is too old, but I would expect that I could fix it to work with Testopia.  But I cannot find in the code where the tables are even created, so I don't know how to proceed.

Comment 1

6 years ago
You cannot mix Testopia 2.4 for Bugzilla 3.6 with Bugzilla 3.2 (which is why the tarball includes BUGZILLA-3.6 in its name). The fact that your Bugzilla is heavily customized probably makes thing worse.

This is not the right place to ask for help. Please visit http://www.mozilla.org/projects/testopia/ for help.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.