[OTA update] After restart, update shows a busted homescreen with no apps

VERIFIED FIXED

Status

VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: tchung, Assigned: cjones)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Whiteboard: [ota update])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
I'm not sure if i just updated to a bad Build, or the installer is busted.  Anyway, after a successful OTA update (woohoo!), the UI dialog asks me to Restart.  

FIrst off, pressing restart didnt work.  none of the buttons did anything, including the hardware buttons on this dialog screen.
So i was forced to pull battery and reboot.
Once rebooted, the lockscreen came up, with the Lock slider.   
Unlock the screen, and your'e stuck on the Search homepage.  There are no apps shown.


Steps to reproduce:

1. load the 2012-09-16 EU build onto an otoro phone
2. force an OTA update using https://gist.github.com/7acb26790bf3dd0bd71e
3. wait ~2 minutes and the phone will begin downloading the update
4. If you're on a fast network, watch the updater progress nicely and ask the user to restart the phone the end
5. Try clicking the "restart" button.  notice nothing happens
6. Pull battery and reboot the phone.
7. Verify upon rebooting, and unlocking the lockscreen, there is nothing on the homescreen (no apps, just a blank search icon and the background image)

Expected:
Updated to the latest build.  

Actual:
I can't tell if i updated successfully, and i'm stuck with a busted homescreen with no apps
Fabrice, is this what you and Marshall were investigating today?  Who's the right owner?
blocking-basecamp: --- → +
I think Marshall is the owner here, at least to investigate exactly what's going wrong. I have a patch with better way to prevent race conditions in the activities registration code but that was not the issue Marshall saw.

Updated

6 years ago
Duplicate of this bug: 791830

Updated

6 years ago
Assignee: nobody → marshall

Comment 4

6 years ago
Can we investigate this as a P1 Marshall? Let us know if you have trouble reproducing.
FYI, I've been working pretty much exclusively on tracking this one down. Thanks to cjones' help, we may've found the culprit.

It looks like permissions for /system/b2g are getting changed after an update to 0750, which causes the spawned content process to terminate shortly after it is forked.
Created attachment 662378 [details] [diff] [review]
updater umask needs to be 0022

Whoever gets this first, feel free to steal the review.
Assignee: marshall → jones.chris.g
Attachment #662378 - Flags: review?(marshall)
Attachment #662378 - Flags: review?(dhylands)
Attachment #662378 - Flags: review?(dhylands) → review+
Attachment #662378 - Flags: review?(marshall)
https://hg.mozilla.org/mozilla-central/rev/ca4f5cf1fbed
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
So the patch only addresses the homescreen coming up blank. There is still the issue of the Restart button not doing anything. Is that going to be a separate bug?
That patch is awaiting review.
(Reporter)

Comment 11

6 years ago
(In reply to Chris Jones [:cjones] [:warhammer] from comment #10)
> That patch is awaiting review.

Is there a bug tracking this patch?
(Reporter)

Comment 13

6 years ago
Verified fix against 9-30 -> 10-01 ota update.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.