{% trans %} blocks are extracted into the templates/main.lang file but can't be merged into ab-CD/main.lang

RESOLVED FIXED

Status

P2
minor
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: pascalc, Assigned: pascalc)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: u=user c=l10n p=)

(Assignee)

Description

6 years ago
the base.html and base-responsive.html use a {% trans %} block allowing passing variables to the copyright notice text in the footer, but I can't export that string into main.lang.

Here is the text:

{% trans url='/foundation/licensing/website-content.html' %}
Portions of this content are ©1998–{{ current_year }} by individual
mozilla.org contributors. Content available under
a <a href="{{ url }}">Creative Commons license</a>.
{% endtrans %}

The Bedrock documentation says that {% trans %} block behave like _() calls but allow larger blocks of text and passing multiple variables.

steps to reproduce:
1/ manage.py l10n_extract
2/ manage.py l10n_merge pt-BR

Step 1 does correctly update templates/main.lang with the following string, but Step 2 does not extract these strings into ab-CD/main.lang
(Assignee)

Comment 1

6 years ago
mmm, I think I got it working today so it might have been fixed by code improvements in the contribute branch merge yesterday or I was hitting a bug I can't reproduce today. Keeping open until I get time to test more but lowering priority because today it works and I also have the workaround of adding the string with a script to the files.
Severity: normal → minor
Hi Pascal-

Let's add this to the list of bugs to fix/close in anticipation of the MWC wave.

Do you want to assign to someone else to test?

Thx,
Jen
Assignee: nobody → pascalc
Priority: -- → P2
Whiteboard: u=user c=l10n p=
(Assignee)

Comment 3

6 years ago
I just tested again and it works now, it was maybe fixed by the work on trans blocks in Bug 808580
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.