Last Comment Bug 792061 - Print Weekly Schedule Includes Incorrect Data & Dates
: Print Weekly Schedule Includes Incorrect Data & Dates
Status: RESOLVED FIXED
: regression
Product: Calendar
Classification: Client Software
Component: Printing (show other bugs)
: Lightning 1.7
: All All
: -- major (vote)
: 1.9
Assigned To: Stefan Sitter
:
:
Mentors:
: 795857 800868 (view as bug list)
Depends on: 794585
Blocks: 757902
  Show dependency treegraph
 
Reported: 2012-09-18 08:25 PDT by Tim Johnson
Modified: 2012-10-15 04:41 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
20120918 Lightning Print Problem.pdf (11.72 KB, application/octet-stream)
2012-09-18 08:25 PDT, Tim Johnson
no flags Details
Bug 792061 - printing trial (19.01 KB, application/pdf)
2012-09-20 00:04 PDT, danimura
no flags Details
Bug 792061 - printing trial 2 (22.98 KB, application/pdf)
2012-09-20 04:04 PDT, danimura
no flags Details
Bug 792061 - printing trial 3 (29.90 KB, application/pdf)
2012-09-20 04:12 PDT, danimura
no flags Details

Description Tim Johnson 2012-09-18 08:25:30 PDT
Created attachment 662174 [details]
20120918 Lightning Print Problem.pdf

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:15.0) Gecko/20100101 Firefox/15.0.1
Build ID: 20120905151427

Steps to reproduce:

Select Print/Weekly Planner Layout/Events only (i.e. deselect Tasks)
Default setting is Week Starting Monday


Actual results:

The printed page has the following errors:
- the date for Monday (top left box) has the correct Events in it, BUT is labelled with the date for the following Monday, e.g. shows as 24 September today.
- the data for Sunday (bottom left box) intermittently is either blank, or displays Events from another day.  (NB not evidenced on the attached example).


Expected results:

This used to work perfectly in the previous versions of FF, TB & Lightning so has only just started to malfunction.
This is a fabulous Add On, but only if it works properly.
Comment 1 danimura 2012-09-20 00:04:47 PDT
Created attachment 662830 [details]
Bug 792061 - printing trial

Monday date is wrong. Events are right. Allday events shows twice: "Tutto il giorno–Tutto il giorno" = Allday-Allday
Comment 2 Tim Johnson 2012-09-20 02:26:51 PDT
I'm sorry, but Events aren't completely right.  I need to print >1 week's Calendar from time to time for family use.  If you do this, the print output "loses" Events on some Sundays.

(I could forward PDFs to show this effect if I knew how?!)

Otherwise this is a fantastic bit of software.

Thanks.
Comment 3 danimura 2012-09-20 04:04:58 PDT
Created attachment 662955 [details]
Bug 792061 - printing trial 2

Ok! In these 2 Weeks printing I can see an error in the first day (for me is Monday): the first Monday shows the events for the first and second Monday, while the second Monday printed (= the third in my Calendar) in incorrectly wide. Thanks!
Comment 4 danimura 2012-09-20 04:12:03 PDT
Created attachment 662958 [details]
Bug 792061 - printing trial 3

I submit another printing job. In these 4 Weeks printing I can see also an error in the number of the week (38 for 1 and 2; 40 for 3 e 4); now the second Monday printed is full. The incorrectly wide Monday is the last. Regards!
Comment 5 Stefan Sitter 2012-09-20 10:14:13 PDT
Most probably another regression from Bug 757902.
Comment 6 Stefan Sitter 2012-10-06 01:24:33 PDT
*** Bug 795857 has been marked as a duplicate of this bug. ***
Comment 7 Stefan Sitter 2012-10-12 04:36:56 PDT
*** Bug 800868 has been marked as a duplicate of this bug. ***
Comment 8 bagu 2012-10-12 05:59:39 PDT
The bug happen also on windows 7 64bit and gentoo 64bits.
Comment 9 Stefan Sitter 2012-10-12 08:42:24 PDT
Should be fixed with the patch in Bug 794585.
 https://hg.mozilla.org/comm-central/rev/c311d81476a4
 https://hg.mozilla.org/releases/comm-aurora/rev/1f1c1c48c3b3

I'd appreciate if you could verify the bug fix using Lightning 1.9 Beta 2 once available or using one of the current 2.0a2 or 2.1a1 nightly test build.
Comment 10 Tim Johnson 2012-10-15 01:38:12 PDT
I have tried to install Lightning 1.9 Beta 2 using the instructions on the site (save to PC, install from file etc.) but nothing happens!  I still show as having 1.8 installed even if I re-start.  Sorry to be obtuse, but should I be doing something else to be able to test this beta version?  I updated to TB 16.0.1 before I tried this beta version.  
If I have actually installed the beta (e.g. if it doesn't display as such in About but is there anyway) then the fix hasn't worked on my PC.
Thanks for all your efforts on this.  I really appreciate it.
Comment 11 Stefan Sitter 2012-10-15 01:42:41 PDT
The fix is not available in Lightning 1.8 for Thunderbird 16. Lightning 1.9 Beta requires Thunderbird 17 Beta.
Comment 12 Decathlon 2012-10-15 03:18:23 PDT
I've just tested on Thunderbird 18.0a2 (2012-10-11) with Lightning 2.0a2 BuildID=20121014002550

it seems all correct if you start the week on Monday, but if you set, in the View options, the start of the week on Sunday, in the weekly planner you get for every week the Sunday and related events of the previous week, e.g. in the week 40 from 1/10/2012 to 7/10/2012 you get the Sunday 30/9/2012 instead of the 7/10/2012 one.
Comment 13 Stefan Sitter 2012-10-15 04:41:55 PDT
(In reply to Decathlon from comment #12)
Known problem (Bug 375043).

Note You need to log in before you can comment on or make changes to this bug.