Malformed URLs in advanced search throw a 500 (regression in Web QA negative-search test)

VERIFIED WONTFIX

Status

Socorro
Webapp
--
major
VERIFIED WONTFIX
5 years ago
4 years ago

People

(Reporter: stephend, Assigned: adrian)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fromAutomation], URL)

(Reporter)

Description

5 years ago
Post bug 791889, test_that_malformed_urls_on_query_do_not_return_500_error is failing:

https://crash-stats-dev.allizom.org/query/query?product=Firefox&version=ALL%3AALL&range_value=1&range_unit=weeks&date=09%2F18%2F2012+16%3A36%3A59&query_search=signature&query_type=contains&query=&reason=&build_id=http%3A%2F%2Fwww.google.com&process_type=any&hang_type=any&do_query=1
(Assignee)

Updated

5 years ago
Target Milestone: 20 → 21
(Assignee)

Updated

5 years ago
Target Milestone: 21 → Future
(Assignee)

Comment 1

5 years ago
This should be fixed in the django UI. Won't fix in the PHP app.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

5 years ago
Target Milestone: Future → ---
Bumping to QA verified on stage and prod - a 400 is returned. Note the test is still failing due to the page not being templated. Bug 913549 filed to track this.

[10:51:32.438] GET https://crash-stats.allizom.org/query/?product=Firefox&version=ALL%3AALL&range_value=1&range_unit=weeks&date=09%2F18%2F2012+16%3A36%3A59&query_search=signature&query_type=contains&query=&reason=&build_id=http%3A%2F%2Fwww.google.com&process_type=any&hang_type=any&do_query=1 [HTTP/1.1 400 BAD REQUEST 278ms]
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.