About Mozilla dialog shold be XUL-ified and all text externalized to entities

RESOLVED WORKSFORME

Status

()

P4
normal
RESOLVED WORKSFORME
18 years ago
10 years ago

People

(Reporter: karl, Unassigned)

Tracking

({l12y})

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
The About Mozilla (Help menu) should be XUL-ified and the entitites
externalized, so that it will be easier to localize. This will also make it
easier to change the name 'Mozilla' to 'Communicator' for Netscape.

As an added bonus, the dialog will also look more "native", i.e., will look like
the rest of Mozilla, even when you change themes.

Comment 1

18 years ago
Adding keyword l12y.  Changing QA contact to ylong@netscape.com.
Keywords: l12y
QA Contact: andreasb → ylong

Comment 2

18 years ago
huftis, it is not clear in your descriptopn. Do you talk about the pull down 
menu item "About Mozilla" or about page about.html?

Comment 3

18 years ago
Reassigned to verah.
Assignee: rchen → verah

Comment 4

18 years ago
--> Help
Assignee: verah → rchen
QA Contact: ylong → andreasb

Updated

17 years ago
QA Contact: andreasb → ylong

Comment 5

17 years ago
worksforme - the dialog is "XUL-ified" if you have that pref turned on. Enable 
it by going to prefs and clicking "Show About as modal dialog" checkbox in the 
debug panel.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

17 years ago
> worksforme - the dialog is "XUL-ified" if you have that pref turned on.

No, it's not. It's still just a HTML file. Reopening.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Summary: About Mozilla dialog shold be XUL-ified → About Mozilla dialog shold be XUL-ified and all text externalized to entities

Comment 7

17 years ago
Karl, the dialog is made in XUL if you have that pref from the debug panel
checked. Do resolve back.
(Reporter)

Comment 8

17 years ago
> Karl, the dialog is made in XUL if you have that
> pref from the debug panelchecked.

No, only the dialog "window" is in XUL. The contents is still a HTML file (an 
invalid HTML file, BTW), which is difficult to localize.

Comment 9

17 years ago
Karl, In what sense is it hard to localize?  It's just some text.  

BTW, the HTML won't be invalid after the fix for bug 88686 is in.

Comment 10

17 years ago
I don't think localzing about.html is a big deal. But if there is a easy way to 
make it a xul, we should do it. 

Reassign to the owner of the file, mcafee.

mcafee, if you don't own it, please reassign it to the right person. Thanks.
Assignee: rchen → mcafee
Status: REOPENED → NEW

Comment 11

17 years ago
over to vishy to find an owner.
Assignee: mcafee → vishy
Since its not a bug deal to localize about.html, we will not XULIfy this for now
at least. we will consider in time for the next netscape release. 
Keywords: nsbeta1

Comment 13

17 years ago
nav triage team:

marking nsbeta1+, p4, and mozilla1.1
Keywords: nsbeta1 → nsbeta1+
Priority: -- → P4
Target Milestone: --- → mozilla1.1

Updated

17 years ago
Keywords: nsBranch

Comment 14

17 years ago
Marking nsbranch- as it was decided in the August bug triage that we wouldn't
have enough time in eMojo to fix this.  Let's revisit for MachV.
Keywords: nsbranch-

Comment 15

17 years ago
removed keyword nsbranch since it now has nsbranch-, per pdt mtg.
Keywords: nsbranch

Updated

17 years ago
Blocks: 107067

Updated

17 years ago
Keywords: nsbranch-

Comment 16

17 years ago
rchen - reassigning to rchen since Vishy is no longer with us. 
Assignee: vishy → rchen

Comment 17

17 years ago
-> pchen.
Assignee: rchen → pchen

Comment 18

17 years ago
->default assignee
Assignee: pchen → rchen
QA Contact: ylong → ruixu
Target Milestone: mozilla1.1 → ---

Updated

17 years ago
QA Contact: ruixu → ylong

Comment 19

17 years ago
Karl, do you mind fixing the bug?

Comment 20

17 years ago
back to pchen. CC msanz.
Assignee: rchen → pchen

Comment 21

17 years ago
->nobody
Assignee: pchen → nobody

Comment 22

15 years ago
Why was this bug being ignored until now?
I just see it has been assigned to nobody and I wonder why since it has been
more than a year since this was reported and still no fix...
Status: NEW → RESOLVED
Last Resolved: 17 years ago10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.