Closed Bug 792226 Opened 7 years ago Closed 7 years ago

IonMonkey: Crash reloading in PDF.js

Categories

(Core :: JavaScript Engine, defect, critical)

defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 793257

People

(Reporter: dvander, Assigned: dvander)

References

Details

(Keywords: crash, Whiteboard: [ion:p1:fx18])

Crash Data

Steps to repro are in bug 719114 comments 52 and 56. I can get it just by refreshing the PDF a whole bunch.
Blocks: 719114
Duplicate of this bug: 791814
This PDF that Gary found is also quite crashy: http://www.straitstimes.com/sites/straitstimes.com/files/ST_20120914_SWIPHONE14_3298937.pdf

For me, the browser crashes immediately when loading it.
Thanks! That one crashes immediately for me as well.
Severity: normal → critical
Crash Signature: [@ js::GCMarker::processMarkStackTop ] [@ js::GCMarker::processMarkStackTop(js::SliceBudget&)]
Keywords: crash
OS: Linux → All
Hardware: x86_64 → All
Duplicate of this bug: 793614
http://atratus.se/david/20120921_se_stockholm.pdf is another example of a crash while viewing a pdf that goes away if you set ion.content to false. The reporter said to load the file, then scroll around, and eventually it will crash.
Crash Signature: [@ js::GCMarker::processMarkStackTop ] [@ js::GCMarker::processMarkStackTop(js::SliceBudget&)] → [@ js::GCMarker::processMarkStackTop ] [@ js::GCMarker::processMarkStackTop(js::SliceBudget&)][@ GCGraphBuilder::NoteXPCOMChild(nsISupports*) | nsDOMEvent::cycleCollection::TraverseImpl(nsDOMEvent::cycleCollection*, void* nsCycleCollectionTraversalCallba…
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 793257
Note that bug fixes rendering issues as well.
No longer blocks: 719114
You need to log in before you can comment on or make changes to this bug.