[RFE] Implement Password Creating Screen for Wallet/Signon

VERIFIED DUPLICATE of bug 13022

Status

()

Toolkit
Form Manager
P3
enhancement
VERIFIED DUPLICATE of bug 13022
19 years ago
9 years ago

People

(Reporter: Paul MacQuiddy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
It would be nice to see a standard password creation screen for
wallet/singlesignon to avoid mistypes when putting in your password for the
first time.

The current way of things is to simply establish the first password entered as
the password. In addition to the problem with mistyping, it is also fairly
confusing, since people (at least me) are led to believe that they have already
established a password, which they haven't.

I think this is pretty important to get implemented.

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M10

Comment 1

19 years ago
Can't do that unless a new dialog format is created to accomodate two passwords.
But I can address the second part of this report right now -- namely the
confusion.  I just checked in a fix so that you get two distinctively different
messages -- one for initial creation of the password and one for specifying the
password to open the data base.

Pushing the "standard password screen" part of this report  out to M10 and will
do it only if time permits.
(Reporter)

Comment 2

19 years ago
Maybe you can do something like bring up the password dialogues twice
consecutively the first time and make sure they match.

Comment 3

19 years ago
Yes, I could.  But it would be throw-away code once the correct dialog is
available.  So it's not worth spending the half day or so to make this change
now.
(Reporter)

Comment 4

19 years ago
Okay, just a suggestion, didn't know how hard the 'correct' dialogue was going
to be.

Updated

19 years ago
Target Milestone: M10 → M8

Updated

19 years ago
Target Milestone: M8 → M10

Comment 5

19 years ago
Oops, meant to change the TFV of another bug to M8 and changed this one by
accident.  Restoring to M10

Updated

18 years ago
Target Milestone: M10 → M12

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 6

18 years ago
A meeting was held yesterday to discuss wallet UE issues.  Bug 13022 was opened
to track all issues agreed to at that meeting.  The enhancement requested in the
current bug report was one of those agreed to and now included in bug 13022.  So
this report is being closed out as a duplicate.

*** This bug has been marked as a duplicate of 13022 ***

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 7

18 years ago
verified dup...see bug 13022
Assignee: morse → nobody
Component: Form Manager → Form Manager
Product: Core → Toolkit
QA Contact: paulmac → form.manager
Target Milestone: M12 → ---
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.