Thunderbird "Know your rights" information tab persists across relaunches

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: dave.koelmeyer, Unassigned)

Tracking

17 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
On launching Earlybird for the first time I receive the "Know your rights" notification in the notification bar, with a button to either close the notification or look at the rights page. Clicking on the rights page button displays rights information in a new tab as you'd expect. I then closed Earlybird.

The expected results in the Earlybird test currently running say that on closing Earlybird and re-launching it, this tab should no longer appear, which is not the case on my system: the tab persists across launches of Earlybird unless it is manually closed. Note that the notification in the notification bar *doesn't* reappear.
(Reporter)

Updated

6 years ago
Blocks: 789883

Comment 1

6 years ago
Why is it a problem? TB should preserve tabs that were open.
Is this one tab an exception by design? Maybe only the test description is wrong?
(Reporter)

Comment 2

6 years ago
I've registered this as a bug as it fails the test I've been asked to carry out. I have no opinion myself as to whether this is a problem or not.
(Reporter)

Comment 3

6 years ago
The same behaviour is observed for Ubuntu Linux 12.04 x86. Please let me know if you need me to open a separate bug report.

Comment 4

6 years ago
No need for a new bug yet, this "problem" is inside TB regardless of OS.
OS: Windows 7 → All
Hardware: x86_64 → All

Comment 5

6 years ago
dave, can you cite the URL of the test?  shoulld be in your browser history (it willl be helpful) 
thanks
(Reporter)

Comment 6

6 years ago
Hi Wayne, I believe it's this (for Ubuntu)

https://litmus.mozilla.org/single_result.cgi?id=605055

For the same test on Windows, I believed it failed as well but I seem to have submitted it incorrectly as a pass:

https://litmus.mozilla.org/single_result.cgi?id=604744

Comment 7

5 years ago
I installed Earlybird 23.0a2 (2013-06-12) and created a new profile. I got the "know your rights" notification when I ran it. I didn't click on the button.  I exited and ran Earlybird with the same profile. I got a request to report performance information instead. The next time I ran it with that profile there were no notifications. 

I noticed mail.rights.version was set to 1. I "reset" it using the config editor, exited, and launched Earlybird again with the same profile. This time I clicked on the know your rights button and it displayed the expected text. I exited Earlybird and ran it again with the same profile.  There were no notifications.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.