bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

getting JS exceptions in nsBrowserContentListener.js

VERIFIED WORKSFORME

Status

SeaMonkey
UI Design
P4
normal
VERIFIED WORKSFORME
17 years ago
14 years ago

People

(Reporter: Scott MacGregor, Assigned: Stephen P. Morse)

Tracking

Trunk
mozilla0.9.4

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
when reading mail messages, I keep getting the following exception in
nsBrowserContentListener.js (which I was suprised to see is no longer a C++
object =(. Are we not worried that page loading will be slower if we always have
to go out to JS to see if the window can handle a particular content type??) I
didn't think this code seemed like good code to be in JS.


************************************************************
* Call to xpconnect wrapped JSObject produced this error:  *
[Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILAB
LE) [nsIURIContentListener.canHandleContent]"  nsresult: "0x80040111 (NS_ERROR_N
OT_AVAILABLE)"  location: "JS frame :: chrome://navigator/content/nsBrowserConte
ntListener.js :: anonymous :: line 134"  data: no]
************************************************************

Comment 1

17 years ago
what build? I just fixed this at 7:30am this morning

Comment 2

17 years ago
Alec: I'm still seeing this after your fix this morning. The guilty line of code is:

  return contentListener.canHandleContent(contentType, command, windowTarget,
                                          desiredContentType);

My tree is up to date (I have nsBrowserContentListener.js rev 1.3).
OS: Windows 2000 → All
Hardware: PC → All
(Reporter)

Comment 3

17 years ago
I'm seeing this with a debug build from noon TODAY. So post your fix this
morning =).

Comment 4

17 years ago
i also seeing this when visiting flash pages, example brought by a user on irc
was http://games.sohu.com/fightgame/fight3.swf

Not sure if that is the reason why the flash does not show andonly sound
happens, but that causes the same warning message in console.

Comment 5

17 years ago
deleting a msg and loading the next message has gotten really slow. I wonder if
this is related. Adding self to cc list.

Comment 6

17 years ago
when displaying a message, doesn't the uri loader ask the current window first,
before it goes off and tries other windows?
I'm also getting this when browsing, in particular I get this error twelve (12!)
times each time I search using http://bugzilla.mozilla.org/quicksearchhack.html
Keywords: mozilla0.9.2, nsbeta1
nav pretriage: propose moving to mozilla0.9.2. 

Comment 9

17 years ago
nav triage team:

marking nsbeta1+ and mozilla0.9.2
Keywords: nsbeta1 → nsbeta1+
Target Milestone: --- → mozilla0.9.2

Comment 10

17 years ago
I'm getting nearly the same error, bug notice that the line is now 131, not 
134...

Error: [Exception... "Component returned failure code: 0x80040111 
(NS_ERROR_NOT_AVAILABLE) [nsIURIContentListener.canHandleContent]"  
nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: 
chrome://navigator/content/nsBrowserContentListener.js :: anonymous :: line 
131"  data: no]
Source File: chrome://navigator/content/nsBrowserContentListener.js
Line: 131


And I get this 3 times after a search at the page that dveditz mentioned:

http://bugzilla.mozilla.org/quicksearchhack.html

jake

Comment 11

17 years ago
Also, bug 81251 is probably a dup of this

jake

Comment 12

17 years ago
no, it doesn't - look the exception is basically harmless - please stop posting
to this bug "I see this too!" - we all see it, and it has nothing to do with any
crashes, and it's not hurting anyone right now except filling up their console
with spew.
Status: NEW → ASSIGNED
Priority: -- → P2

Comment 13

17 years ago
*** Bug 81251 has been marked as a duplicate of this bug. ***
*** Bug 81797 has been marked as a duplicate of this bug. ***
nav triage: not an m0.9.2 stopper, moving to m0.9.3 at least. 
Priority: P2 → P4
Target Milestone: mozilla0.9.2 → mozilla0.9.3

Comment 16

17 years ago
nav triage team:

Annoying spewage to the console, but won't hold 0.9.3 for it. Marking mozilla1.0
Target Milestone: mozilla0.9.3 → mozilla1.0

Comment 17

17 years ago
nav triage team:

Steve, can you look into this? Reassigning to morse@netscape.com and moving up
to mozilla0.9.4
Assignee: alecf → morse
Status: ASSIGNED → NEW
Target Milestone: mozilla1.0 → mozilla0.9.4
(Assignee)

Comment 18

17 years ago
I'm not seeing this.  I tried both reading mail messages and also using dveditz' 
search and didn't get an error either time.  If you can still reproduce, then 
reopen.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
v.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.