unable to push to hg.m.o/projects/cedar

RESOLVED FIXED

Status

Developer Services
General
RESOLVED FIXED
5 years ago
3 years ago

People

(Reporter: aki, Assigned: bkero)

Tracking

Details

(Reporter)

Description

5 years ago
(bb08)deathduck:/src/mh-talos/cedar [11:53:13] (default)
981$ hg push
pushing to ssh://hg.mozilla.org/projects/cedar
searching for changes
remote: adding changesets
remote: adding manifests
remote: adding file changesremote: added 7705 changesets with 97076 changes to 15389 files
remote: error: changegroup.z_loghistory hook raised an exception: attempt to write a readonly database


In theory, I should have commit level 3 privs, per bug 790721.
Does Cedar have bad permissions on its commit db ?
(Reporter)

Updated

5 years ago
Depends on: 774973
(Reporter)

Updated

5 years ago
Severity: normal → major

Updated

5 years ago
Assignee: server-ops-devservices → bkero
(Assignee)

Comment 1

5 years ago
-rw-r--r--   1                  48 scm_level_2    0 Jul 26 18:54 pushlog2.db

chmod g+w fixed it.  Don't know the root cause of it yet, amd am sprinting to get git.m.o up by deadline, so I don't have time to find the root cause.  Dropping priority and leaving it open to find out why the perms were created wrong.
Severity: major → normal
(Reporter)

Comment 2

5 years ago
Thanks, Ben.

Seems to have gotten us to the next error:

(bb08)deathduck:/src/mh-talos/cedar [12:29:48] (default)
876$ hg push
pushing to ssh://hg.mozilla.org/projects/cedar
searching for changes
remote: adding changesets
remote: adding manifests
remote: adding file changes
remote: added 118 changesets with 720 changes to 553 files
remote: error: changegroup.z_loghistory hook raised an exception: [Errno 1] Operation not permitted: '/repo/hg/mozilla/projects/cedar/.hg/pushlog2.db'
(Assignee)

Comment 3

5 years ago
Was owned by uid 48 (not sure why).  I've chown'd it to hg, please try again
(Reporter)

Comment 4

5 years ago
Works! Thank you.

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Component: Server Operations: Developer Services → General
Product: mozilla.org → Developer Services
You need to log in before you can comment on or make changes to this bug.