Closed Bug 792570 Opened 7 years ago Closed 7 years ago

IonMonkey: crash in EnterIon

Categories

(Core :: JavaScript Engine, defect, critical)

18 Branch
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 791589

People

(Reporter: marcia, Unassigned)

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-af16b79f-5b6d-4c39-b056-1cfb02120919 .
============================================================= 

Seen while looking at trunk crash stats. Low volume crash which started appearing in crash stats on 2012091208. Because of the URLs, wondering if it is the same as Bug 791589?

Frame 	Module 	Signature 	Source
0 		@0x11b2ad1ea 	
1 	XUL 	EnterIon 	Ion.cpp:1325
2 	XUL 	js::ion::CanEnter 	Ion.cpp:1252
3 	XUL 	js::Interpret 	jsinterp.cpp:2483
4 	libnspr4.dylib 	PR_GetCurrentThread 	ptthread.c:583
5 	libnspr4.dylib 	PR_SetThreadPrivate 	prtpd.c:139
6 	XUL 	js::mjit::EnterMethodJIT 	MethodJIT.cpp:1046
7 	XUL 	js::RunScript 	jsinterp.cpp:325
8 	XUL 	js::InvokeKernel 	Stack.h:1640 


Some URLs:

Total Count 	URL
1 	http://www.mapy.cz/
1 	http://www.mapy.cz/#x=18.259302&y=49.850395&z=17&d=stre_111688_1&t=s&q=ostrava%2
1 	http://www.syngames.net/game/braidjump
1 	http://www.mapy.cz/#q=Blansko&t=s&x=17.150352&y=49.615874&z=7
1 	http://blog.sethladd.com/2011/09/box2d-collision-damage-for-javascript.html
1 	http://www.mapy.cz/#q=vla%25C5%25A1im&t=s&x=14.921433&y=49.714183&z=12&d=muni_35
1 	http://www.mapy.cz/#q=Blansko&t=s&x=16.739228&y=49.291748&z=10&l=15
1 	http://tour.golang.org/#1
1 	http://mapy.cz/
1       http://www.mattpelham.com/vii/
Fix for 791589 just landed on m-i, should be available in 2012-09-21 nightly.
Summary: crash in EnterIon → IonMonkey: crash in EnterIon
Yup, this seems to have dropped off after the 9-20 build.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 791589
You need to log in before you can comment on or make changes to this bug.