Closed Bug 792626 Opened 9 years ago Closed 1 year ago

crash @ RuleHash::AppendRule(RuleSelectorPair const&) with ATI graphics card

Categories

(Core :: Layout, defect)

15 Branch
x86
All
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox48 --- affected
firefox49 --- affected
firefox-esr45 --- affected
firefox50 --- affected

People

(Reporter: philipp, Unassigned)

Details

(Keywords: crash)

Crash Data

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20120918042011

Steps to reproduce:

a user in the support forums has reported crashes, frozen screens and BSODS.
https://support.mozilla.org/questions/937444#answer-369330

one of the crash signatures i couldn't yet find a bug for was @ RuleHash::AppendRule(RuleSelectorPair const&)
https://crash-stats.mozilla.com/report/index/1a1fe738-220b-4423-9c09-30da22120914

i don't know if it's significant or might be related, but other crashes on his system were:
Bug 643840 - Crash [@ WrappedNativeSuspecter ] 
https://crash-stats.mozilla.com/report/index/121a8309-fe00-4eac-8390-596b62120919
Bug 725009 - crash in js::GCHelperThread::doSweep
https://crash-stats.mozilla.com/report/index/d9737947-04dd-45ac-8452-99d462120919
https://crash-stats.mozilla.com/report/index/242c0175-3697-4b79-be1b-97abc2120918
https://crash-stats.mozilla.com/report/index/7d98b11d-05b3-4086-a834-4d9412120919
Bug 762987 - EXCEPTION_STACK_OVERFLOW crash in PresShell::HandlePostedReflowCallbacks 
https://crash-stats.mozilla.com/report/index/8ca8685d-5aa3-4e43-b30f-a68062120917
Crash Signature: [@ RuleHash::AppendRule(RuleSelectorPair const&) ]
Severity: normal → critical
Keywords: crash
Does it happen in Safe Mode (see https://support.mozilla.org/kb/troubleshoot-firefox-issues-using-safe-mode)?
Component: General → Style System (CSS)
Hardware: x86_64 → x86
the OP claims he has tackled the problem by switching graphics cards.
specifically the reporter wrote " I've removed the ATI card - enabled hardware acceleration and have had no further Firefox crashes or BSOD's."

So I suppose we charge the the problem specific to this user to hardware.  Unfortunately the specific card and driver version is not mentioned
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Component: CSS Parsing and Computation → Graphics
Resolution: --- → INCOMPLETE
Summary: crash @ RuleHash::AppendRule(RuleSelectorPair const&) → crash @ RuleHash::AppendRule(RuleSelectorPair const&) with ATI graphics card
This was reported again in bug 1007089, on Linux this time.

I'll see if that user can report more information about their graphics hardware in case this is an ATI card issue. Until then, moving back to Layout component.
Status: RESOLVED → REOPENED
Component: Graphics → Layout
Ever confirmed: true
Flags: needinfo?(bhearsum)
OS: Windows 7 → All
Resolution: INCOMPLETE → ---
(In reply to Mike Conley (:mconley) from comment #4)
> This was reported again in bug 1007089, on Linux this time.
> 
> I'll see if that user can report more information about their graphics
> hardware in case this is an ATI card issue. Until then, moving back to
> Layout component.

The laptop I was using at the time had an Intel card, actually.
Flags: needinfo?(bhearsum)
Crash Signature: [@ RuleHash::AppendRule(RuleSelectorPair const&) ] → [@ RuleHash::AppendRule(RuleSelectorPair const&) ] [@ RuleHash::AppendRule ]
Crash volume for signature 'RuleHash::AppendRule':
 - nightly (version 50): 2 crashes from 2016-06-06.
 - aurora  (version 49): 5 crashes from 2016-06-07.
 - beta    (version 48): 68 crashes from 2016-06-06.
 - release (version 47): 247 crashes from 2016-05-31.
 - esr     (version 45): 21 crashes from 2016-04-07.

Crash volume on the last weeks:
            W. N-1  W. N-2  W. N-3  W. N-4  W. N-5  W. N-6  W. N-7
 - nightly       0       1       0       1       0       0       0
 - aurora        1       1       0       0       1       0       2
 - beta         13      10      12       9       7       9       5
 - release      32      33      27      38      35      32      33
 - esr           1       5       0       3       1       3       1

Affected platforms: Windows, Mac OS X, Linux

Closing because no crashes reported for 12 weeks.

Status: REOPENED → RESOLVED
Closed: 8 years ago1 year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.