Closed Bug 792647 Opened 7 years ago Closed 7 years ago

All Marionette telephony tests are failing on "cold boot"

Categories

(Core :: DOM: Device Interfaces, defect)

All
Gonk (Firefox OS)
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla19
Tracking Status
firefox18 --- fixed
firefox19 --- fixed

People

(Reporter: jgriffin, Assigned: jgriffin)

References

Details

Attachments

(1 file)

Since https://tbpl.mozilla.org/?rev=0c8ac138706e, all Marionette telephony tests are failing on CI, mostly timing out, but a few with other errors.  Non-telephony tests mostly pass.

I can reproduce the failures locally as well.  However, if I manually launch an emulator and wait a minute or so, and then run the tests against the running emulator, they pass.

It seems like we may need to have the tests wait for something before starting, but I'm not sure what we should be waiting for.

See logs at http://brasstacks.mozilla.com/autolog/?tree=b2g&source=autolog&rev=0b6677a9d5ed3cd8f0dd95f39cd3a0a204129d76
Could you please narrow down the regression to a specific changeset/bug? Thanks!
(In reply to Philipp von Weitershausen [:philikon] from comment #1)
> Could you please narrow down the regression to a specific changeset/bug?
> Thanks!

I had a few regression tests and it doesn't seem to be bound in a certain range. Some failed "cold boot" test cases listed in the autolog link still have the possibility to pass with or without 0c8ac138706e. But if you comment out "system-message-listener-ready" event waiting in RadioInterfaceLayer, most cases passed as usual.
So should Marionette also be waiting for "system-message-listener-ready" before returning an emulator over to test control?
(In reply to Jonathan Griffin (:jgriffin) from comment #3)
> So should Marionette also be waiting for "system-message-listener-ready"
> before returning an emulator over to test control?
Grr, hit reply too soon.

(In reply to Jonathan Griffin (:jgriffin) from comment #3)
> So should Marionette also be waiting for "system-message-listener-ready"
> before returning an emulator over to test control?

Probably not a bad idea for now, although we may remove "system-message-listener-ready" again in favour of the mechanism implemented in bug 783149.

Robert, can you investigate please? Thanks!
Assignee: nobody → rwood
(In reply to Jonathan Griffin (:jgriffin) from comment #3)
> So should Marionette also be waiting for "system-message-listener-ready"
> before returning an emulator over to test control?

My marionette tests wait for voice network connected event, which waits for "system-message-listener-ready". But sometimes "system-message-listener-ready" just never gets fired by Gaia in emulator, so I comment out "system-message-listener-ready" waiting in writing marionette tests for now.
This patch allows the telephony tests to pass, let me know if you prefer a different fix.
Attachment #669802 - Flags: review?(philipp)
review ping. We're trying to get WebAPI tests running on TBPL and this is one of the last few remaining issues.
Attachment #669802 - Flags: review?(philipp) → review+
https://hg.mozilla.org/mozilla-central/rev/484a0c8aacea
Assignee: rwood → jgriffin
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
Ugh, this breaks mochitest, because that even never fires after we load the mochitest profile and reboot mochitest.
Blocks: 802807
Whiteboard: [automation-needed-in-aurora]
You need to log in before you can comment on or make changes to this bug.