diabloii.net - server returns text/plain mimetype

VERIFIED FIXED

Status

Tech Evangelism Graveyard
English US
P4
normal
VERIFIED FIXED
17 years ago
3 years ago

People

(Reporter: Havoc Pennington, Assigned: bc)

Tracking

Details

(Whiteboard: [SYNTAX-HTTP], URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.1-0.1.9smp i686; en-US; rv:0.8.1+)
Gecko/20010425
BuildID:    2001042512

I don't think this is a bug in that Mozilla is probably doing the morally right
thing, but it is a difference from Internet Explorer. IE somehow manages to
display http://www.diabloii.net as rendered HTML. Mozilla, Netscape 4, and Lynx
all think it should be displayed as plain text.

Probably the server is broken, but it's broken in a way that IE works around,
and so the webmasters don't seem to be noticing, and your average user would
conclude that Mozilla is broken.

Filing against the http component on the random guess that MIME type recognition
might be there and this might be related to MIME types. 

No doubt the web site will get fixed eventually, so if you can't reproduce,
sorry about that. :-(

A nice workaround to offer users without selling out to standards incompliance
might be a "View as..." option to allow you to force a MIME type on some data.
i.e. a menu where I could choose "View as HTML" and force the text to be
interpreted as text/html.

Reproducible: Always
Steps to Reproduce:
1.go to http://www.diabloii.net

Actual Results:  HTML source as plain text

Expected Results:  Rendered as HTML, emulating IE? Or maybe a "lame server
detected, flame the Internet Explorer developers" nastygram-creation wizard?
The server returns:

HTTP/1.1 200 OK
Date: Tue, 08 May 2001 08:05:58 GMT
Server: Apache/1.3.14 (Unix)
Connection: close
Content-Type: text/plain

and we honor that.  There is no way to detect that the server is being "lame" --
it is doing everythin per spec.  It's just got the wrong mimetype...  and
presumably has a good reason for doing so.  IE overrides the server's returned
content-type based on whatever the weather in South America is that day.

Over to evangelism to get the server admins notified.
Assignee: neeti → bclary
Status: UNCONFIRMED → NEW
Component: Networking: HTTP → Evangelism
Ever confirmed: true
QA Contact: tever → zach
OS: Linux → All
Hardware: PC → All
Summary: displays HTML source as text → server returns text/plain mimetype
(Assignee)

Updated

17 years ago
Whiteboard: [SYNTAX-HTTP]
(Assignee)

Updated

17 years ago
Priority: -- → P4
(Assignee)

Updated

17 years ago
Summary: server returns text/plain mimetype → diabloii.net - server returns text/plain mimetype
(Assignee)

Comment 2

17 years ago
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified
(Reporter)

Comment 3

17 years ago
The web site has long-since fixed its content type, I assume this should be closed.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 4

17 years ago
Verified
2002022703/WinXP
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.