[b2g-bluetooth] BluetoothService::Notify() won't be called after receiving agent events

RESOLVED FIXED in mozilla18

Status

()

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: echou, Assigned: gyeh)

Tracking

unspecified
mozilla18
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

6 years ago
I used latest code to pair with my HTC device but failed. I found that we did receive RequestConfirmation event in AgentEventFilter, in that case BluetoothService::Notify should be called because it registered for LOCAL_AGENT_PATH & REMOTE_AGENT_PATH in Init(). However, if Bluetooth was ever switched off, mBluetoothSignalObserverTable would be clear, and we won't register again.
(Reporter)

Updated

6 years ago
Blocks: 727618
blocking-basecamp: --- → ?

Updated

6 years ago
blocking-basecamp: ? → +

Updated

6 years ago
Assignee: nobody → echou
(Assignee)

Comment 1

6 years ago
Created attachment 664451 [details] [diff] [review]
v1 patch

Since mBluetoothSignalObserverTable (in BluetoothService) is cleared when we stop bluetooth, the entry of LOCAL_AGENT_PATH, REMOTE_AGENT_PATH, and BluetoothManager(/) which should be kept in the table are also removed. 

In this patch, we re-add these entries when bluetooth is started.
Assignee: echou → gyeh
Attachment #664451 - Flags: review?(kyle)
(Assignee)

Comment 2

6 years ago
Created attachment 664751 [details] [diff] [review]
Final version, r=qdot
Attachment #664451 - Attachment is obsolete: true
(Assignee)

Updated

6 years ago
Duplicate of this bug: 789434
https://hg.mozilla.org/mozilla-central/rev/f85da9a728de
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla18
You need to log in before you can comment on or make changes to this bug.