bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Gif images don't fully load, even with refresh

RESOLVED WORKSFORME

Status

()

Core
ImageLib
P3
major
RESOLVED WORKSFORME
17 years ago
17 years ago

People

(Reporter: david, Assigned: Nivedita (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.5-pre1 i686; en-US; rv:0.9)
Gecko/20010505
BuildID:    2001050521

At http://www.playscratchandwin.com, gif images don't fully load, even with
refresh..

Reproducible: Always
Steps to Reproduce:
1. Go to http://www.playscratchandwin.com
2. Look.
3. Buy some tickets :)

Actual Results:  Main logo loads incomplete, featured ticket preview image
doesn't load.

Expected Results:  Show the images as perfectly as IE does!

Images were created in GIMP ...

Comment 1

17 years ago
I can confirm this behavior.  I often see this when trying to read comics.  If I
recall correctly FoxTrot is especially bad.  Scrolling the page so that the
image is covered and the uncovered often makes the image show up.

Comment 2

17 years ago
Marking NEW based on confirmation.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

17 years ago
this site's gifs work for me on winMe cvs 2001053009

Comment 4

17 years ago
I'm a bit curious why such a high-profile bug is still around. Here's a listing
of just a few sites it affects:

http://tigert.gimp.org/ (the header graphic)
http://dilbert.com/ (numerous graphics, but the top-left logo seems to be
related; the other images are other rendering problems, I think...) 

There are many others; I've seen quite a few. I just got back from out of town
however, and those are the two I know for a fact are related.

An interesting note, however, with each one of these sites, if the image is
rendered directly within the browser, such as
http://tigert.gimp.org/pics/ant-title.gif,
http://dilbert.com/comics/dilbert/images/comic_com_logo.gif, and
http://www.playscratchandwin.com/images/logo.gif it displays correctly. It is
only when they are displayed inline that their boundaries are chopped
inappropriately.

FWIW, this is using Linux with Mozilla from post-0.8.1 onward to the latest
nightly (anything with libpr0n, essentially).

Comment 5

17 years ago
Sorry for the spam, but I'm adding one sites where I can systematically 
reproduce the error with Mozilla 20010601 on Win2k.
http://www.jeuxvideo.com/ see the yellow right column (named 'Actualites' with 
news & dates), it drawed correctly weeks ago with Mozilla but when I switched 
to libpr0n, it didn't work fine anymore, there're black striped within.

Updated

17 years ago
Target Milestone: --- → mozilla0.9.2

Updated

17 years ago
Priority: -- → P3

Updated

17 years ago
Target Milestone: mozilla0.9.2 → mozilla0.9.3

Comment 6

17 years ago
-> 0.9.4
Target Milestone: mozilla0.9.3 → mozilla0.9.4

Comment 7

17 years ago
aye.. I have noticed the same problem with "gif" loading, but I have some more
details that may help (or may not)

First of all, I'm using WinME and Win2000, build 20010807 and have this problem.
 Maybe if someone with either of those (or even MacOS) can confirm it, OS can be
changed from Linux.

Secondly, I can solve the problem using Stephen Ostermiller's technique above by
"Scrolling the page so that theimage is covered and the uncovered"

Thirdly, I've noticed the same problem with some "png" images.  Could Mozilla
have a small problem rendering this type of graphic?  (PNG and GIF are very
similar types of graphic files)

And, as an example of a problematic PNG image, I'll include my own site:
http://rpertusio.cjb.net/
Note the logo in the black space at the top of the page, it draws about half of
the image, but can be revealed by redrawing the page (by resizing the window, or
using Stephen's technique above).
[i know my site stinks.. but it's the only example of PNG loading I have available]

Comment 8

17 years ago
Sorry, an additional note about the website address I gave above...  The web
server that I've given is not available at this time due to "code red" worm
floating around.  The server is either [1] infected, or [2] preventing infection.
  It should be available soon.  (again, sorry for this extra spam)

Updated

17 years ago
Target Milestone: mozilla0.9.4 → mozilla0.9.5

Comment 9

17 years ago
.
Target Milestone: mozilla0.9.5 → mozilla0.9.6

Updated

17 years ago
Target Milestone: mozilla0.9.6 → mozilla0.9.8

Updated

17 years ago
Target Milestone: mozilla0.9.8 → mozilla0.9.9

Comment 10

17 years ago
over to nivedita
Assignee: pavlov → nivedita
Target Milestone: mozilla0.9.9 → ---
(Assignee)

Comment 11

17 years ago
I am unable to reproduce this bug on Windows NT and Linux. I tried the 
following sites as mentioned in the bug description, 
a) http://www.playscratchandwin.com
b) http://tigert.gimp.org/
c) http://dilbert.com/
d) http://www.jeuxvideo.com/
e) http://rpertusio.cjb.net/

The images appear correctly. 
If anyone is able to reproduce the bug, can you please upload the steps to 
reproduce the bug.
I am not able to reproduce this with latest mozilla trunk builds:

windows 2002-02-14-09-trunk
linux 2002-02-14-08-trunk
mac osx 2002-02-14-08-trunk

all of the test case pages and their gifs load fine.

(Assignee)

Comment 13

17 years ago
Marking as works for me, as unable to reproduce the bug
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.