Last Comment Bug 792833 - Don't unset current transaction until after savepoint has been released
: Don't unset current transaction until after savepoint has been released
Status: RESOLVED FIXED
[qa?]
:
Product: Core
Classification: Components
Component: DOM: IndexedDB (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla18
Assigned To: Ben Turner (not reading bugmail, use the needinfo flag!)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-20 07:27 PDT by Ben Turner (not reading bugmail, use the needinfo flag!)
Modified: 2012-10-17 16:39 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
affected
wontfix
fixed
fixed


Attachments
Patch, v1 (1.16 KB, patch)
2012-09-20 07:27 PDT, Ben Turner (not reading bugmail, use the needinfo flag!)
khuey: review+
lukasblakk+bugs: approval‑mozilla‑aurora+
lukasblakk+bugs: approval‑mozilla‑beta-
Details | Diff | Splinter Review

Description Ben Turner (not reading bugmail, use the needinfo flag!) 2012-09-20 07:27:14 PDT
Created attachment 663009 [details] [diff] [review]
Patch, v1

Found while looking at bug 792547. Basically the quota prompt will fail if we're in a savepoint release when the quota is exceeded. Simple patch.
Comment 1 Ben Turner (not reading bugmail, use the needinfo flag!) 2012-09-20 10:18:01 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/30ae02a8ce8c
Comment 2 Ben Turner (not reading bugmail, use the needinfo flag!) 2012-09-20 10:20:30 PDT
Comment on attachment 663009 [details] [diff] [review]
Patch, v1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Initial quota management implementation
User impact if declined: Crash and/or undefined behavior when a quota prompt is about to be displayed.
Testing completed (on m-c, etc.): m-i for now, m-c tomorrow
Risk to taking this patch (and alternatives if risky): This patch is exceptionally simple, almost guaranteed to be risk free.
String or UUID changes made by this patch: None
Comment 3 Ryan VanderMeulen [:RyanVM] 2012-09-20 18:33:39 PDT
https://hg.mozilla.org/mozilla-central/rev/30ae02a8ce8c
Comment 4 Lukas Blakk [:lsblakk] use ?needinfo 2012-09-21 16:15:13 PDT
Comment on attachment 663009 [details] [diff] [review]
Patch, v1

It's too late to take this on Beta and check for crash volume on something which has no crash signature or history of crashing so let's put this on Aurora and ride the train from there.
Comment 5 Ben Turner (not reading bugmail, use the needinfo flag!) 2012-09-24 09:44:40 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/2593ecab46c6
Comment 6 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-10-17 16:39:09 PDT
Is there something QA can do to verify this fix?

Note You need to log in before you can comment on or make changes to this bug.