The default bug view has changed. See this FAQ.

lightning nightly broken on Seamonkey nightly since 20120919

RESOLVED FIXED in 1.9

Status

Calendar
Lightning: SeaMonkey Integration
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: u331436, Assigned: Stefan Sitter)

Tracking

({regression})

Lightning 1.9
regression
Dependency tree / graph

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 SeaMonkey/2.15a1
Build ID: 20120920003004

Steps to reproduce:

Installed Lightning nightly versions on Seamonkey nightly.
Since 20120919, lightning is broken


Actual results:

- Missing details in the day pane (no line for hours, no color...)
- unable to switch to week or month view


Expected results:

Normal layout should be seen.
- I tried Safe Mode: unable to reproduce as all add-ons are deactivated
- I tried a test profile with only Lightning: Same issue
(Assignee)

Comment 1

5 years ago
Error: TypeError: node is null
Source File: chrome://calendar/content/calendar-views.js Line: 289

Most probably caused by the check-in for Bug 785480. I assume that "appmenu_calendar-go-menu-next" and "appmenu_calendar-go-menu-previous" is not available without app menu.
Blocks: 785480
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: Lightning 2.0 → Lightning 1.9
(Assignee)

Comment 2

5 years ago
Created attachment 663050 [details] [diff] [review]
regression fix

Patch makes setupViewNode() more robust to not fail on non-existing elements.
Assignee: nobody → ssitter
Status: NEW → ASSIGNED
Attachment #663050 - Flags: review?(philipp)
Attachment #663050 - Flags: approval-calendar-aurora?
(Assignee)

Updated

5 years ago
Keywords: regression
Attachment #663050 - Flags: review?(philipp)
Attachment #663050 - Flags: review+
Attachment #663050 - Flags: approval-calendar-aurora?
Attachment #663050 - Flags: approval-calendar-aurora+
(Assignee)

Comment 3

5 years ago
Pushed to https://hg.mozilla.org/comm-central/rev/2a45733640f4
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.0
(Assignee)

Comment 4

5 years ago
Pushed to https://hg.mozilla.org/releases/comm-aurora/rev/56eb9486736f
Target Milestone: 2.0 → 1.9

Updated

5 years ago
Blocks: 785692
You need to log in before you can comment on or make changes to this bug.