Firefox 15.0.1 redraw error - when navigating page or filling forms the page is not changed

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: ota, Unassigned)

Tracking

15 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 663023 [details]
system-environment.txt

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.4 (KHTML, like Gecko) Chrome/22.0.1229.56 Safari/537.4

Steps to reproduce:

Using mouse scrolling (or scroll bar), navigating the page using PgUp/PgDn/Home/End keys, trying to fill out forms or visiting some pages with scripted content.


Actual results:

The displayed content is not changed; no page movement, no text appears in the forms and scripted portions of pages are not displayed correctly or at all. When switching to different workspace or window (even other firefox window or tab) and back the page changes correctly based on the previous navigation action, typing or page-script actions. 
One nice example of incorrect display of scripted content is http://acid3.acidtests.org/ which sometimes finishes with result 1/100 and no rendered picture, then upon reload on 48/100 or 56/100 and partial rendering. In all cases switching to other window and back produces correct 100/100 with fully rendered picture.
I have tried beta of Firefox 16 with no improvement (this was binary downloaded directly from mozilla.org , version 15.0.1 was from linux distribution Gentoo and compiled on my machine). It is not affected by different settings of smooth scrolling, autoscrolling or hardware acceleration.
Since I haven't seen it reported (only on one ubuntu forum without reply) I suspect it might be graphic card related and so not very common.


Expected results:

The page should be redrawn based on navigation action, typed text should appear and scripted content should change the page immediately without having to use the switching elsewhere and back to the window method.
(In reply to ota from comment #0)
> Created attachment 663023 [details]
> system-environment.txt
> 
> User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.4 (KHTML, like
> Gecko) Chrome/22.0.1229.56 Safari/537.4
> 
> Steps to reproduce:
> 
> Using mouse scrolling (or scroll bar), navigating the page using
> PgUp/PgDn/Home/End keys, trying to fill out forms or visiting some pages
> with scripted content.

Can you please provide a link to a test page ?
(Reporter)

Comment 2

5 years ago
It seems that I have solved the problem.
After deleting the preferences folder .mozilla (and first backing up important stuff using Sync) and restarting with addons disabled (I have tried this before but without wiping out preferences) everything works. Then I have reinstalled all addons via Sync and the problem came back so I have started enabling addons gradually and the culprit seems to be "Translate this!" addon (version 1.9). However, it is not so straightforward. This addon is the only one that I have which does not need restart after enabling/disabling so tinkering is less painful. My last conclusion is that the problems start only after I move the addon icon from Addon-bar to "Navigation toolbar" (where the url address row is located) using the "Customize" from context menu when rightclicking on one of the bars. If I move the icon back to addon-bar the problem is gone.

I will try to investigate more and if the conclusion will hold I will close this bug and report to addon developer probably.
(Reporter)

Comment 3

5 years ago
(In reply to Paul Silaghi [QA] from comment #1)
> (In reply to ota from comment #0)
> > Created attachment 663023 [details]
> > system-environment.txt
> > 
> > User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.4 (KHTML, like
> > Gecko) Chrome/22.0.1229.56 Safari/537.4
> > 
> > Steps to reproduce:
> > 
> > Using mouse scrolling (or scroll bar), navigating the page using
> > PgUp/PgDn/Home/End keys, trying to fill out forms or visiting some pages
> > with scripted content.
> 
> Can you please provide a link to a test page ?

I assume you mean where the problems arise, basically anywhere:
For scrolling e.g. http://slashdot.org
For scripted page (as posted in the bug report) e.g. http://acid3.acidtests.org

Comment 4

4 years ago
Hello.  Any update?
(In reply to ota from comment #3)
> For scrolling e.g. http://slashdot.org
> For scripted page (as posted in the bug report) e.g.
> http://acid3.acidtests.org
Everything's ok on FF 23.0.1, 26.0a1 (2013-09-09) Ubuntu 13.04 x64
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.