Some 10.8 slaves reporting TEST-UNEXPECTED-FAIL | test_bug519468.js | en-US == en

RESOLVED FIXED

Status

task
RESOLVED FIXED
7 years ago
a year ago

People

(Reporter: khuey, Unassigned)

Tracking

({intermittent-failure})

Details

+++ This bug was initially created as a clone of Bug #635244 +++

Looks like its locale settings are wrong.

Please fix.
It's not just that one (it's a large enough set that I didn't think it had anything to do with the slave, but recent?numbuilds=1000 and filtering on beta xpcshell does say that none of the first three I looked at had ever done a successful xpcshell run on beta).

But why does it only fail on beta? Did we fix that test to not fail outside the United States for 17?
What do you expect the locale settings on the mountain lion slaves to be?  We don't explicitly change them in Puppet.
en-US, rather than the en it's apparently set to - just like there's no timezone other than Mountain View, there's no locale other than en-US.

I'm half inclined to just push http://hg.mozilla.org/mozilla-central/rev/9819f1e610ef down to beta, since it's test-only, except for the niggling feeling that it might bite us later if we really do have a mix of locales, rather than it being en on all the slaves but only some of the slaves actually have a problem (bug 557024 implies without saying straight out that it did not affect everyone with a non-en-US locale).
So, two questions:

1. What is the locale set to on 084 (fails) and 061 (passes)?
2. If they are different, how does that make us feel?
The locales on the two slaves are the same

talos-mtnlion-r5-084:~ root# defaults read -g AppleLocale
en_US
talos-mtnlion-r5-061:~ root# defaults read -g AppleLocale
en_US

Updated

7 years ago
Blocks: 438871
Depends on: 557024
I'm betting this will have been fixed by pushing https://hg.mozilla.org/releases/mozilla-beta/rev/aa77ad5b8f49
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Summary: talos-mtnlion-r5-084 is reporting TEST-UNEXPECTED-FAIL | test_bug519468.js | en-US == en → Some 10.8 slaves reporting TEST-UNEXPECTED-FAIL | test_bug519468.js | en-US == en
Whiteboard: [orange]
Product: mozilla.org → Release Engineering

Updated

a year ago
Product: Release Engineering → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.