The default bug view has changed. See this FAQ.

Event dialog broken due to FileLink feature [Error: ReferenceError: cloudFileAccounts is not defined]

RESOLVED FIXED in 1.8

Status

Calendar
Lightning: SeaMonkey Integration
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Stefan Sitter, Assigned: Fallen)

Tracking

({regression})

Lightning 1.8
regression
Dependency tree / graph

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Lightning 2.0a1 + Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 SeaMonkey/2.15a1

Opening the event dialog throws the following errors:

> Error: NS_ERROR_FILE_NOT_FOUND: Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIXPCComponents_Utils.import]
> Source File: chrome://calendar/content/calendar-event-dialog.js 
> Line: 8

> Error: ReferenceError: cloudFileAccounts is not defined
> Source File: chrome://calendar/content/calendar-event-dialog.js 
> Line: 1641
(Reporter)

Comment 1

5 years ago
Same problem using Lightning 1.8b1 + Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20120912 Firefox/16.0 SeaMonkey/2.13.
OS: Windows 7 → All
Hardware: x86_64 → All
Summary: Event dialog problem due to FileLink feature [Error: ReferenceError: cloudFileAccounts is not defined] → Event dialog broken due to FileLink feature [Error: ReferenceError: cloudFileAccounts is not defined]
Version: Lightning 2.0 → Lightning 1.8
(Assignee)

Comment 2

5 years ago
Created attachment 663367 [details] [diff] [review]
Fix - v1

I must admit I didn't test this in Seamonkey, but I did test by not importing the file and setting the pref to false, so this should fix it. Stefan, I'd appreciate if you could give this a quick test and a review.
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Attachment #663367 - Flags: review?
Attachment #663367 - Flags: approval-calendar-beta?
Attachment #663367 - Flags: approval-calendar-aurora?
(Assignee)

Updated

5 years ago
Attachment #663367 - Flags: review? → review?(ssitter)
(Reporter)

Updated

5 years ago
Attachment #663367 - Flags: review?(ssitter)
Attachment #663367 - Flags: review+
Attachment #663367 - Flags: approval-calendar-beta?
Attachment #663367 - Flags: approval-calendar-beta+
Attachment #663367 - Flags: approval-calendar-aurora?
Attachment #663367 - Flags: approval-calendar-aurora+
(Reporter)

Comment 3

5 years ago
Philipp, do you need help with check-in?
(Assignee)

Comment 4

5 years ago
Sorry, forgot about this one. If you have a moment, could you check it in?
(Reporter)

Comment 5

5 years ago
Pushed to https://hg.mozilla.org/comm-central/rev/811000b2e134
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.0
(Reporter)

Comment 6

5 years ago
Pushed to https://hg.mozilla.org/releases/comm-aurora/rev/d9d66183a1a5
Target Milestone: 2.0 → 1.9
(Reporter)

Comment 7

5 years ago
Pushed to https://hg.mozilla.org/releases/comm-beta/rev/fd1c64237446
Target Milestone: 1.9 → 1.8

Updated

5 years ago
Blocks: 785692
You need to log in before you can comment on or make changes to this bug.