Reset Sync (Push) on client A unlinks client B if it tries to Reset Sync (Pull)

RESOLVED WONTFIX

Status

Cloud Services
Firefox Sync: Backend
--
critical
RESOLVED WONTFIX
6 years ago
2 years ago

People

(Reporter: tracy, Unassigned)

Tracking

({regression, regressionwindow-wanted})

unspecified
x86
All
regression, regressionwindow-wanted
Points:
---

Firefox Tracking Flags

(firefox16-, firefox17-)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 663137 [details]
pull failure log

Seen going both ways between nightly Aurora 17 on Mac and 16Beta on Win XP.

STR:

0) Setup both clients connected to Sync account and fully synced to each other.
1) On client A, go to Preferences(Options) > Sync > Manage Account > Reset Sync... and proceed with "Replace all other devices with the computer's data"
2) allow the Sync to complete then immediately
3) On Client B, go to Preferences(Options) > Sync > Manage Account > Reset Sync... and proceed with "Replace all data on this computer with my Sync data"
4) after failure of this Sync, shutdown and restart client B.

Tested results:
At step 3, the wipe completes, but the download of data from the cloud doesn't take place.

After restart, the client is no longer connected to the account from step 0.  The only way to recover from wiped data is to reconnect to the account.  Which does successfully get all data from the cloud.

from attached log: 
1348170352784	Sync.Service	DEBUG	Exception: Could not acquire lock. Label: "service.js: sync". No traceback available
1348170352784	Sync.Service	INFO	Cannot start sync: already syncing?

Expected results:
The account completes the wipe phase then successfully downloads all data from Sync cloud.

Comment 1

6 years ago
Yikes. I'm going to look at this immediately. Can you look into 15 and fill in the bug tracking flags? This needs to get on release drivers' radar.
(Reporter)

Comment 2

6 years ago
Just to be clear, if you do the Client A Reset, push to cloud. Then follow it up with a regular Sync Now on client B, all is good; local wipe completes and is followed by a successful pull.

Asking for tracking 16 and 17. When I went to repro against 15, I couldn't and all previous reproducible paths starting working correctly :-/
tracking-firefox16: --- → ?
tracking-firefox17: --- → ?

Comment 3

6 years ago
Tracking for upcoming releases and adding regressionwindow-wanted. A backout would be preferable here, if we fix at all. It's not clear how common a Sync reset really is.
tracking-firefox16: ? → +
tracking-firefox17: ? → +
Keywords: qawanted, regression, regressionwindow-wanted

Comment 4

6 years ago
I wasn't able to repro this with yesterday's Nightly :/ I guess I'll try harder.

Comment 5

6 years ago
@Alex: Please fix this even if resetting sync is uncommon for regular users. Resetting sync is very useful in order to reproduce other unrelated bugs, which is where this issue came up first (see bug 756385, comment 7). It's really annoying when other bugs mask the real bug you're trying to reproduce.

Comment 6

6 years ago
(In reply to Sebastian Schuberth from comment #5)
> @Alex: Please fix this even if resetting sync is uncommon for regular users.
> Resetting sync is very useful in order to reproduce other unrelated bugs,
> which is where this issue came up first (see bug 756385, comment 7). It's
> really annoying when other bugs mask the real bug you're trying to reproduce.

We'll definitely fix the first opportunity we can, after weighing risk and reward.

Comment 7

6 years ago
(In reply to Gregory Szorc [:gps] from comment #4)
> I wasn't able to repro this with yesterday's Nightly :/ I guess I'll try
> harder.

Any luck?
Assignee: nobody → gps
Gregory, how can we help in QA to help it move along?
(Reporter)

Comment 9

6 years ago
juanb: other than those first few times, I haven't been able to reproduce my own bug here.

It's a very edge case set of STR's because of doing Reset requests from each client. Also, see my note about the pull not happening in Step 3, which is part of the trigger for this bug.  Even if this some how can be found to reproduce, I think the fix for bug 792990 will prevent this from happening in builds that get that fix.
(Reporter)

Comment 10

6 years ago
(In reply to Alex Keybl [:akeybl] from comment #7)
> (In reply to Gregory Szorc [:gps] from comment #4)
> > I wasn't able to repro this with yesterday's Nightly :/ I guess I'll try
> > harder.
> 
> Any luck?

Alex, without being able to reliably reproduce this, even myself, the only one that experienced it, we're not going to be able to find a regression window, if there is one.
Removing qawanted. I think we've done a good effort of reproducing this problem with not much luck.
Keywords: qawanted
Given the lack of reproducibility, also untracking for release.
tracking-firefox16: + → -
tracking-firefox17: + → -

Updated

5 years ago
Assignee: gps → nobody
Reset sync is not an option in FxA Sync, so closing.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.