Use mozilla-central bundle to speed up hg share bootstrapping for try

RESOLVED FIXED

Status

Release Engineering
General
RESOLVED FIXED
6 years ago
19 days ago

People

(Reporter: nthomas, Assigned: rail)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

6 years ago
catlee sketched this out on IRC. In
  http://ftp.mozilla.org/pub/mozilla.org/firefox/bundles/
we symlink mozilla-central.hg to try.hg, and comm-central.hg to try-comm-central.hg. Then in TryBuildFactory we remove the bundles=[] hardcode in
 http://hg.mozilla.org/build/buildbotcustom/file/default/process/factory.py#l1997

Then new slaves will first grab a the bundle which is pretty close and we save the hg servers a big headache. Even if it's a week old is much better than cloning from scratch.
(Reporter)

Updated

6 years ago
Component: Release Engineering: Automation (Release Automation) → Release Engineering: Automation (General)
QA Contact: release → catlee

Updated

6 years ago
Duplicate of this bug: 793146
Assignee: nobody → rail
Created attachment 663418 [details] [diff] [review]
use bundles for try

Symlinks to be created on ftp
Attachment #663418 - Flags: review?(catlee)
Comment on attachment 663418 [details] [diff] [review]
use bundles for try

Review of attachment 663418 [details] [diff] [review]:
-----------------------------------------------------------------

don't forget on dev-stage01 as well
Attachment #663418 - Flags: review?(catlee) → review+
# ffxbld@stage and dev-stage01
 cd /pub/mozilla.org/firefox/bundles/
 ln -s mozilla-central.hg try.hg
# tbirdbld@stage (no such directory on dev-stage01)
 cd /pub/mozilla.org/thunderbird/bundles/
 ln -s comm-central.hg try-comm-central.hg
looks like working:

python /builds/slave/try-lnx/tools/buildfarm/utils/retry.py -s 1 -r 5 -t 3660 python /builds/slave/try-lnx/tools/buildfarm/utils/hgtool.py --clone-by-revision --mirror http://hg-internal.dmz.scl3.mozilla.com/try --bundle http://ftp.mozilla.org/pub/mozilla.org/firefox/bundles/try.hg http://hg.mozilla.org/try build
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

6 years ago
(In reply to Rail Aliiev [:rail] from comment #5)
Mayeb worth capturing in puppet ?
(In reply to Nick Thomas [:nthomas] from comment #7)
> (In reply to Rail Aliiev [:rail] from comment #5)
> Mayeb worth capturing in puppet ?

yeah, this a good idea.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Created attachment 665083 [details] [diff] [review]
puppet-manifests

for dev-stage01
Attachment #665083 - Flags: review?(catlee)
Created attachment 665085 [details] [diff] [review]
[svn] productdelivery

for stage
Attachment #665085 - Flags: review?(nthomas)
(Reporter)

Comment 11

6 years ago
Comment on attachment 665085 [details] [diff] [review]
[svn] productdelivery

Making these relative links is more tolerant of rearranging of mounts or prefixes in the future, r+ with that.
Attachment #665085 - Flags: review?(nthomas) → review+

Updated

6 years ago
Attachment #665083 - Flags: review?(catlee) → review+
Comment on attachment 665085 [details] [diff] [review]
[svn] productdelivery

svn commit -m "Bug 793087 - Use mozilla-central bundle to speed up hg share bootstrapping for try. r=nthomas"
Sending        manifests/ftp.pp
Transmitting file data .
Committed revision 48776.
Attachment #665085 - Flags: checked-in+
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
Component: General Automation → General
Product: Release Engineering → Release Engineering
You need to log in before you can comment on or make changes to this bug.