Closed Bug 793197 Opened 7 years ago Closed 7 years ago

Multiple selection dropdown listbox options are not visible [ICS] [JB]

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 18
Tracking Status
firefox18 --- verified
fennec 18+ ---

People

(Reporter: ioana.chiorean, Assigned: wesj)

References

Details

(Keywords: regression)

Attachments

(4 files, 2 obsolete files)

Build ID: 18.0 (2012-09-22) Nightly Channel
Device:  Galaxy Nexus 
OS: 4.1.1

Steps to reproduce:
1. Open Fennec -> go to bugzila.mozilla.org -> search - Advance tab
2. Tap on Product options - pan the list 

Actual results:
- Multiple selection dropdown listbox options are not visible 
- reproducible on other sites with multiple selection dropdown listbox 
- reproducible only on JB and ICS Android OS 

Expected results:
- Multiple selection dropdown listbox options should be visible
This was caused by bug 785994. Looking into a fix....
Depends on: 785994
Nominating for tracking, since this is major loss of functionality on Web forms that use <select multiple>.
tracking-fennec: --- → ?
Assignee: nobody → wjohnston
Attached patch Patch (obsolete) — Splinter Review
I'm not quite sure why we have this listViewStyle. Is it required for devices with a hardware menu button? This seems fine to me, but I'd like to understand a bit better where this should show up.
Attachment #664716 - Flags: review?(sriram)
Comment on attachment 664716 [details] [diff] [review]
Patch

Oh please no! This listViewStyle is used by custom menu. And we are moving towards this approach of specifying a "common" style at application/activity level. I'll fix it in Prompt in a different way.
Attachment #664716 - Flags: review?(sriram) → review-
sriram, just tell me how you want it fixed if you want. I think the alternative is to write a custom style for these list items?
Duplicate of this bug: 794915
tracking-fennec: ? → 18+
Keywords: regression
Attached patch Patch v2 (obsolete) — Splinter Review
I really hate that we're not just using native styles, but if we're not we need to override the textColor in this layout. This is a simple way to do that, and I think we want this fixed before we branch next week.
Attachment #664716 - Attachment is obsolete: true
Attachment #667082 - Flags: review?(sriram)
(In reply to Wesley Johnston (:wesj) from comment #7)
> Created attachment 667082 [details] [diff] [review]
> Patch v2
> 
> I really hate that we're not just using native styles, but if we're not we
> need to override the textColor in this layout. This is a simple way to do
> that, and I think we want this fixed before we branch next week.

I would be happy to use default views given by Android in that case -- without we ourselves calling android.R.layout.something. In which case, we don't have to override anything.
Attached patch Patch v2Splinter Review
Whoops. Missed disabled item styling. Also broke pre-gingerbread phones. This fixes both for me. I'll post screenshots from both devices.
Attachment #667082 - Attachment is obsolete: true
Attachment #667082 - Flags: review?(sriram)
Attachment #667163 - Flags: review?(sriram)
Comment on attachment 667163 [details] [diff] [review]
Patch v2

Review of attachment 667163 [details] [diff] [review]:
-----------------------------------------------------------------

This looks good to me.
Attachment #667163 - Flags: review?(sriram) → review+
https://hg.mozilla.org/mozilla-central/rev/0b9c37de03a2
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 18
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.