Core Dump in theme_image_unref

VERIFIED DUPLICATE of bug 7528

Status

Core Graveyard
Tracking
P3
normal
VERIFIED DUPLICATE of bug 7528
19 years ago
2 years ago

People

(Reporter: cyrus, Assigned: Ramiro Estrugo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Dumps core here:

(gdb) bt
#0  0x4099db00 in theme_image_unref ()
#1  0x406c48a0 in g_list_foreach ()
#2  0x4099db89 in theme_data_unref ()
#3  0x4099e326 in theme_destroy_style ()
#4  0x40625ab8 in gtk_style_destroy ()
#5  0x40625312 in gtk_style_unref ()
#6  0x40653e08 in gtk_widget_real_destroy ()
#7  0x405b7326 in gtk_container_destroy ()
#8  0x40658abb in gtk_marshal_NONE__NONE ()
#9  0x4061f568 in gtk_signal_real_emit ()
#10 0x4061d800 in gtk_signal_emit ()
#11 0x40604bea in gtk_object_shutdown ()
#12 0x40653daf in gtk_widget_shutdown ()
#13 0x40604b9b in gtk_object_destroy ()
#14 0x4064d467 in gtk_widget_destroy ()
#15 0x400f59de in nsWidget::Destroy (this=0x8920ef8) at nsWidget.cpp:165
#16 0x411e3dd8 in nsView::~nsView (this=0x8920e90, __in_chrg=3) at
nsView.cpp:142
#17 0x411e418f in nsView::Destroy (this=0x8920e90) at nsView.cpp:247
#18 0x40e51c98 in nsFrame::~nsFrame (this=0x87d48e0, __in_chrg=0) at
nsFrame.cpp:187
#19 0x40e68c11 in nsLeafFrame::~nsLeafFrame (this=0x87d48e0, __in_chrg=0) at
nsLeafFrame.cpp:29
#20 0x40f332da in nsFormControlFrame::~nsFormControlFrame (this=0x87d48e0,
__in_chrg=0)
    at nsFormControlFrame.cpp:75
#21 0x40f35f52 in nsButtonControlFrame::~nsButtonControlFrame (this=0x87d48e0,
__in_chrg=3)
    at nsButtonControlFrame.cpp:560
#22 0x40e52301 in nsFrame::DeleteFrame (this=0x87d48e0, aPresContext=@0x87f7ab8)
at nsFrame.cpp:390
#23 0x40ff7083 in nsFrameList::DeleteFrames (this=0x87d47d8,
aPresContext=@0x87f7ab8) at nsFrameList.cpp:28
#24 0x40e6560d in nsInlineFrame::DeleteFrame (this=0x87d47a0,
aPresContext=@0x87f7ab8)
    at nsInlineFrame.cpp:326
#25 0x40e6961b in nsLineBox::DeleteLineList (aPresContext=@0x87f7ab8,
aLine=0x87e3ac8) at nsLineBox.cpp:157
#26 0x40e4388f in nsBlockFrame::DeleteFrame (this=0x87e3708,
aPresContext=@0x87f7ab8)
    at nsBlockFrame.cpp:806
#27 0x40e6961b in nsLineBox::DeleteLineList (aPresContext=@0x87f7ab8,
aLine=0x891ce70) at nsLineBox.cpp:157
#28 0x40e4388f in nsBlockFrame::DeleteFrame (this=0x88919c0,
aPresContext=@0x87f7ab8)
    at nsBlockFrame.cpp:806
#29 0x40e6961b in nsLineBox::DeleteLineList (aPresContext=@0x87f7ab8,
aLine=0x891d430) at nsLineBox.cpp:157
#30 0x40e4388f in nsBlockFrame::DeleteFrame (this=0x871c160,
aPresContext=@0x87f7ab8)
    at nsBlockFrame.cpp:806
#31 0x40e6961b in nsLineBox::DeleteLineList (aPresContext=@0x87f7ab8,
aLine=0x86ee098) at nsLineBox.cpp:157
#32 0x40e4388f in nsBlockFrame::DeleteFrame (this=0x888d8b8,
aPresContext=@0x87f7ab8)
    at nsBlockFrame.cpp:806
#33 0x40e41992 in nsAreaFrame::DeleteFrame (this=0x888d8b8,
aPresContext=@0x87f7ab8) at nsAreaFrame.cpp:105
#34 0x40ff7083 in nsFrameList::DeleteFrames (this=0x8580870,
aPresContext=@0x87f7ab8) at nsFrameList.cpp:28
#35 0x40e4fbad in nsContainerFrame::DeleteFrame (this=0x8580838,
aPresContext=@0x87f7ab8)
    at nsContainerFrame.cpp:79
#36 0x40ff7083 in nsFrameList::DeleteFrames (this=0x86f0480,
aPresContext=@0x87f7ab8) at nsFrameList.cpp:28
#37 0x40e4fbad in nsContainerFrame::DeleteFrame (this=0x86f0448,
aPresContext=@0x87f7ab8)
    at nsContainerFrame.cpp:79
#38 0x40ff7083 in nsFrameList::DeleteFrames (this=0x81c6738,
aPresContext=@0x87f7ab8) at nsFrameList.cpp:28
#39 0x40e4fbad in nsContainerFrame::DeleteFrame (this=0x81c6700,
aPresContext=@0x87f7ab8)
    at nsContainerFrame.cpp:79
#40 0x40e876c6 in ViewportFrame::DeleteFrame (this=0x81c6700,
aPresContext=@0x87f7ab8)
    at nsViewportFrame.cpp:115
#41 0x40e73d3e in PresShell::~PresShell (this=0x87e6268, __in_chrg=3) at
nsPresShell.cpp:548
#42 0x40e73a9b in PresShell::Release (this=0x87e6268) at nsPresShell.cpp:485
#43 0x400a4478 in nsCOMPtr_base::~nsCOMPtr_base (this=0x8885124, __in_chrg=2) at
nsCOMPtr.cpp:25
---Type <return> to continue, or q <return> to quit---
#44 0x4003d2ff in nsCOMPtr<nsIPresShell>::~nsCOMPtr (this=0x8885124,
__in_chrg=2)
    at nsWebShellWindow.cpp:757
#45 0x40ff226b in DocumentViewerImpl::~DocumentViewerImpl (this=0x8885100,
__in_chrg=3)
    at nsDocumentViewer.cpp:240
#46 0x40ff1f78 in DocumentViewerImpl::Release (this=0x8885100) at
nsDocumentViewer.cpp:184
#47 0x402f6a17 in nsWebShell::Embed (this=0x8345c00, aContentViewer=0x87dbe58,
aCommand=0x888b120 "view",
    aExtraInfo=0x0) at nsWebShell.cpp:765
#48 0x402f410c in nsDocumentBindInfo::OnStartBinding (this=0x8927218,
aURL=0x891e940,
    aContentType=0x891e8d8 "text/html") at nsDocLoader.cpp:1432
#49 0x402dad8d in NET_NGLayoutConverter (format_out=38, converter_obj=0x0,
URL_s=0x893bb30,
    context=0x88db928) at nsStubContext.cpp:949
#50 0x402b27ed in NET_StreamBuilder (format_out=38, URL_s=0x893bb30,
context=0x88db928) at mkstream.c:237
#51 0x40273e51 in NET_CacheConverter (format_out=38, converter_obj=0x0,
URL_s=0x893bb30,
    window_id=0x88db928) at mkcache.c:1689
#52 0x402b27ed in NET_StreamBuilder (format_out=102, URL_s=0x893bb30,
context=0x88db928) at mkstream.c:237
#53 0x401d581f in net_finish_setup_http_stream (ce=0x85985c8) at mkhttp.c:2877
#54 0x401d51cc in net_setup_http_stream (ce=0x85985c8) at mkhttp.c:2645
#55 0x401d69b9 in net_ProcessHTTP (ce=0x85985c8) at mkhttp.c:3558
#56 0x402a958e in NET_ProcessNet (ready_fd=0x8388490, fd_type=2) at
mkgeturl.c:3355
#57 0x402b15f5 in NET_PollSockets () at mkselect.c:298
#58 0x402d3fa2 in nsNetlibService::NetPollSocketsCallback (aTimer=0x87b1300,
aClosure=0x8098268)
    at nsNetService.cpp:1244
#59 0x40143205 in TimerImpl::FireTimeout (this=0x87b1300) at nsTimer.cpp:73
#60 0x4014368a in nsTimerExpired (aCallData=0x87b1300) at nsTimer.cpp:196
#61 0x406c5fa3 in g_timeout_dispatch ()
#62 0x406c52c6 in g_main_dispatch ()
#63 0x406c5801 in g_main_iterate ()
#64 0x406c5979 in g_main_run ()
#65 0x405f3f3a in gtk_main ()
#66 0x400e8d09 in nsAppShell::Run (this=0x807bff0) at nsAppShell.cpp:197
#67 0x4002935d in nsAppShellService::Run (this=0x80796a8) at
nsAppShellService.cpp:402
#68 0x804aa9c in main (argc=1, argv=0xbffff7d4) at nsAppRunner.cpp:573
#69 0x4081ecb3 in __libc_start_main (main=0x8049cb0 <main>, argc=1,
argv=0xbffff7d4,
    init=0x8049888 <_init>, fini=0x804ba30 <_fini>, rtld_fini=0x4000a350
<_dl_fini>, stack_end=0xbffff7cc)
    at ../sysdeps/generic/libc-start.c:78

Updated

19 years ago
Assignee: don → ramiro
Component: Apprunner → other

Comment 1

19 years ago
Ramiro, any idea who should get this?

Comment 2

19 years ago
*** This bug has been marked as a duplicate of 7528 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 3

19 years ago
Verified Dup of Bug 7528
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.