Need a way to see more than the few most recent changes by a user

RESOLVED DUPLICATE of bug 1003033

Status

Mozilla Developer Network
Profiles
P2
normal
RESOLVED DUPLICATE of bug 1003033
5 years ago
2 years ago

People

(Reporter: Janet Swisher, Unassigned)

Tracking

Details

(Whiteboard: [type:feature][mentor=fscholz][good first bug])

(Reporter)

Description

5 years ago
Currently, a user's profile page shows only their five most recent changes. On MindTouch, one could page through at least 150 (aggregated) changes.

Updated

5 years ago
Priority: -- → P2
Letting users be able to keep track of what they've been up to (and letting others see as well) is fairly important to give folks a sense of feeling like they're being useful, so I'd like to see this too.
This is fairly important, I often digged (both w/ MindTouch and earlier as a Wikipedia admin) back in the history of users just to see what they did in the past. We should be able to get back without limit, in a paged way of course (not in a single request)
What would we want here?  The last 100 good enough?  Pagination of the entire history?

Comment 4

5 years ago
Pagination of entire history, as Teoli requested.

Updated

5 years ago
Whiteboard: feature request;
Whiteboard: feature request; → [type:feature]
(Reporter)

Comment 5

5 years ago
I suggest a link labelled "See all [N] of [username]'s edits" that opens the revision dashboard, filtered on this user. 

We already have a mechanism to see all their edits; it's just not linked to the profile page. 

Including the number of edits in the link text gives the viewer an immediate sense of how experienced this user is. This is a way of surfacing data that informs the subjective reputation of a user, without implementing a fancy-schancy reputation system (yet).
I had a quick look at this. Adding a pagination conflicts with the pagination already implemented on that view for the submitted demos (a second paginator must not use the same "?page=" parameter in that case).

However, adding a simple link to the revision dashboard and counting the edits should be way easier as Janet mentioned.
The URL is e.g.: https://developer.mozilla.org/en-US/dashboards/revisions?user=<username>
Whiteboard: [type:feature] → [type:feature][mentor=fscholz][good first bug]
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1003033
You need to log in before you can comment on or make changes to this bug.