Cannot Copy URL from Web Console

RESOLVED DUPLICATE of bug 638949

Status

()

Firefox
Developer Tools: Console
--
enhancement
RESOLVED DUPLICATE of bug 638949
5 years ago
5 years ago

People

(Reporter: miserlou, Unassigned)

Tracking

({uiwanted})

15 Branch
x86
Mac OS X
uiwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 663539 [details]
Screen Shot 2012-09-21 at 1.10.30 PM.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:15.0) Gecko/20100101 Firefox/15.0.1
Build ID: 20120905151427

Steps to reproduce:

I am debugging an ajax web application with Web Console.

I want to copy the value of the target logged in the Web Console so that I could manually inspect it further. However, this option is not available and I am forced to take a more tedious, manual route.

Anybody who has debugged a complex web application in Firefox has probably experienced this at some point. It's a minor pain point, but it would make a lot of developers very happy, and the fix is simple.


Actual results:

There is no way to copy the URL! I have to log the entire body, paste it into a text editor and manually extract the desired URL every time.


Expected results:

There should be a right-click menu item to copy the target URL.
(Reporter)

Updated

5 years ago
Severity: normal → enhancement
Component: Untriaged → Developer Tools: Console
Whiteboard: console
(Reporter)

Comment 1

5 years ago
Initially, I beleived that 'Copy' would copy just the URL, but in fact it copies the entire response as a log item, ex:

[13:13:26.474] GET http://input.mozilla.org/media/img/sharing.png [HTTP/1.1 200 OK 114ms]

All this needs is an option to simply copy the target URL.
(Reporter)

Updated

5 years ago
Keywords: uiwanted
Whiteboard: console
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 638949
You need to log in before you can comment on or make changes to this bug.