firefox cannot parse < and > in xml

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: Adarsh, Unassigned)

Tracking

({testcase})

15 Branch
x86_64
Windows 7
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.1 (KHTML, like Gecko) Chrome/21.0.1180.89 Safari/537.1

Steps to reproduce:

am parsing xml containing < and > in a jsp


Actual results:

am getting parse error
But it used work in earlier version of firefox , chrome and explorer


Expected results:

< and > should ve displayed in UI
(Reporter)

Updated

5 years ago
Severity: normal → critical
Priority: -- → P5
(Reporter)

Comment 1

5 years ago
Actually i just discovered that it can parse &gt; i.e i can get '>" on the UI but not &lt;('<')

SO firefox v15 cannot parse &lt; in xml
Please provide a testcase, either attached or as URL
Severity: critical → normal
Priority: P5 → --

Comment 3

5 years ago
Dupe of bug 788444?
Hard to tell given complete lack of steps to reproduce.

Parsing &lt; in XML in general works just fine, of course (try data:text/xml,<root>&lt;</root>), which is where steps describing _exactly_ what is being done come in.

Comment 5

5 years ago
Adarsh, provide a testcase, please.
Flags: needinfo?(admn)
Keywords: testcase-wanted

Comment 6

5 years ago
Created attachment 724265 [details]
file which help you to reproduce the issue

The attached html page will help to reproduce the issue mentioned in this bug.

Updated

5 years ago
Attachment #724265 - Attachment mime type: text/plain → text/html

Updated

5 years ago
Flags: needinfo?(admn)
Keywords: testcase-wanted → testcase

Comment 7

5 years ago
(In reply to Praveen from comment #6)
> Created attachment 724265 [details]
> file which help you to reproduce the issue
> 
> The attached html page will help to reproduce the issue mentioned in this
> bug.

Where is the issue?
<subentry value="g1UFT$94AABaaA:Item:001117-Item&gt;:::Item"></subentry>
is parsed as
<subentry value="g1UFT$94AABaaA:Item:001117-Item>:::Item"></subentry>
in the dialog box.
Flags: needinfo?(praveen.kamatnurkar)

Comment 8

5 years ago
Thats the actual issue. I want to send the data to xml parser which in turns gives parsing error.

This works perfectly in IE9.
Flags: needinfo?(praveen.kamatnurkar)
Our current behavior is the behavior the spec calls for.

Your problem is that you're sending the output of an _HTML_ serializer to an _XML_ parser.  The two languages have different escaping and parsing rules.

If you want to serialize as XML, use an XML serializer.  See http://domparsing.spec.whatwg.org/#the-xmlserializer-interface for example.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.