If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

SunSpider slower on FF 18 than FF 16

RESOLVED INVALID

Status

()

Firefox for Android
General
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: donrhummy, Unassigned)

Tracking

18 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:15.0) Gecko/20100101 Firefox/15.0.1
Build ID: 20120905151427

Steps to reproduce:

Ran Sunspider on a Nexus S 4G (ICS 4.0.4) in both FF18 (nightly) and Firefox Beta.


Actual results:

FF Beta finished in 3303.2ms
FF Nightly finished in 3384.3ms


Expected results:

FF18 should have been significantly faster.

Comment 1

5 years ago
My values are also close (on galaxy nexus) : 

FF Beta: 1807.8
FF Aurora: 1943.2
FF Nightly: 1918.9
80 ms is not that much faster you will see a +/- variation.  you'll have to run a series of run and run a average amongst those series to get a better result.  Just running a benchmark once will not suffice due to outside variation that could affect things such as cpu, process, even temperature of the CPU.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

5 years ago
(In reply to Naoki Hirata :nhirata from comment #2)
> 80 ms is not that much faster you will see a +/- variation.  you'll have to
> run a series of run and run a average amongst those series to get a better
> result.  Just running a benchmark once will not suffice due to outside
> variation that could affect things such as cpu, process, even temperature of
> the CPU.

Whether or not 80ms is a big difference, FF18's Javascript is supposed to be significantly faster, yet it's not. This would seem to indicate something's wrong in the Android version of FF 18 versus the desktop version of FF18.
If you compare 15 and 18 on desktop, is it faster on sunspider for you?

IonMonkey is actually slightly slower at SunSpider on arewefastyet.com. Its possible the JS team decided that wins in other areas were more important than benchmark scores and were willing to accept the small regression.

Or its possible that something regressed.
Also, Mozilla does not believe SunSpider is a good benchmark. We are not making SunSpider regressions a priority, in relation to other benchmarks.
(Reporter)

Comment 6

5 years ago
(In reply to Mark Finkle (:mfinkle) from comment #5)
> Also, Mozilla does not believe SunSpider is a good benchmark. We are not
> making SunSpider regressions a priority, in relation to other benchmarks.

What is a good benchmark that I can test?
You need to log in before you can comment on or make changes to this bug.