Browser link in email opens browser window, but then flips back to email client

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
RESOLVED WORKSFORME
6 years ago
3 years ago

People

(Reporter: Scotty Henderson, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [2012 Fall Equinox])

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20120909 Firefox/15.0.1 SeaMonkey/2.12.1
Build ID: 20120909051100

Steps to reproduce:

For the last 3 releases, I'm on 2.12.1 now, I've noted that every time I click on a web link within an email, the browser either opens OK or if already open, flips to the on top of the email client, but then flips back to the email screen immediately.


Actual results:

 I have to click on the sidebar tab in my Win64 console to go back to the browser and all is fine from that point. This only happens when going from and email link. Links with a browser window simply open a new tab.
AS I can't find any similar problem, I'm wondering if it is Win64 related.


Expected results:

The browser window should have remained on top.
(Reporter)

Comment 1

6 years ago
The last three updates of Seamonkey have come out in fairly rapid sequence and all was fine before that. It is now starting to bug me
Mozilla/5.0 (X11; Linux x86_64; rv:18.0) Gecko/18.0 Firefox/18.0 SeaMonkey/2.15a1 ID:20120921003032 c-c:dbd153b0fa9c m-c:9ae014a115b2

Works for me on SeaMonkey 2.15a1 for Linux64

Note that WOW64 means a 32-bit application (e.g. 32-bit SeaMonkey) on top of 64-bit Windows. AFAIK there are no "true" 64-bit Mozilla builds for Windows yet; see bug support-win64.

"All was fine before but now it isn't": could you say, even approximately, when (between which versions) the problem started to happen?
Keywords: regression, regressionwindow-wanted
Whiteboard: [2012 Fall Equinox]

Comment 3

6 years ago
So far similar focus issues have been traced to the flashplayer plugin. Either update to the latest available Flashplayer plugin or use the Flashplayer plugin configuration to disable protected mode.
I can confirm that the flash player (Version: 11.4.402.265) is currently doing exactly this on my system even with protected mode disabled. This happens only if the flash player starts and not if the flash player is already running.
(Reporter)

Comment 5

6 years ago
OK, I agree, it seems to be a Flash problem. I have the latest Flash 11.4.402.265 and everything else is up to date. I can't confirm which version of SM where it started, but I recall it has only been doing it for about a month, maybe a month and a half. I never paid close attention so I did some tests. For example when clicking on the bugzilla link from an email, no problem, but when I opened a link that used flash the focus went back to email. And once the flash had done that once, subsequent openings of a flash page didn't cause it. I tend to get a lot of emails with embedded flash links but hadn't noticed the relationship.

The question is now, can this be fixed? Is it a Mozilla problem or Flash issue?
Many thanks
(In reply to Scotty Henderson from comment #5)
[...]
> The question is now, can this be fixed? Is it a Mozilla problem or Flash
> issue?
> Many thanks

Hard to tell. It could be a problem in the part of Mozilla that runs Flash, or in Flash itself.
Component: General → Plug-ins
Product: SeaMonkey → Core
Version: SeaMonkey 2.12 Branch → unspecified
Cannot reproduce on FF Nightly 20.0a1 (2012-12-17) Flash 11.5.502.135 Win 7 x64
(In reply to Paul Silaghi [QA] from comment #7)
> Cannot reproduce on FF Nightly 20.0a1 (2012-12-17) Flash 11.5.502.135 Win 7
> x64

Not able to reproduce on Latest Nightly (2013-02-25) and on FF 20.1 on Windows 7 x64. Paul can you confirm this is Resolved WFM?
Not able to reproduce on SeaMonkey 2.16.
Closing the bug, please reopen if you experience this again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.