Bug.search fails with the assigned_to field filled out correctly

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: jonkeinan, Unassigned)

Tracking

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0.1
Build ID: 20120905151427

Steps to reproduce:

I'm writing a small plugin to connect to bugzilla and I'm trying to poll for all the bugs assigned to a specific user.

The xml rpc my program produces is:
<?xml version="1.0"?>
<methodCall>
  <methodName>Bug.search</methodName>
  <params>
    <param>
      <value>
        <struct>
          <member>
            <name>assigned_to</name>
            <value>
              <string><username>@<email>.com</string>
            </value>
          </member>
        </struct>
      </value>
    </param>
  </params>
</methodCall>


Actual results:

I receive the following response:
<?xml version="1.0" encoding="UTF-8"?><methodResponse><fault><value><struct><member><name>faultString</name><value><string>syntax error at (eval 1068) line 2, at EOF
</string></value></member><member><name>faultCode</name><value><int>-32000</int></value></member></struct></value></fault></methodResponse>


Expected results:

I should have received the bugs assigned to that user.

I should mention that when I changed the assigned_to field to creator I received a correct response.

Comment 1

6 years ago
What arguments did you pass to Bug.search exactly? This looks like a support question to me.
(Reporter)

Comment 2

6 years ago
I only passed the assigned_to field as a search parameter.
The value was something in the lines of: myusername@mycompanyname.com

When I changed the 'assigned_to' field into the 'creator' field it functioned well so I assume the problem is not in the email I provided.

Updated

6 years ago
Keywords: qawanted

Comment 3

5 years ago
I tested with Bugzilla 4.2.7 and 4.5.1, and I cannot reproduce your issue. The assigned_to field is working as expected.

If you need help, please visit http://www.bugzilla.org/support.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.