Status

()

RESOLVED INVALID
18 years ago
18 years ago

People

(Reporter: birger.langkjer, Assigned: clayton)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win95; en-US; rv:0.9) Gecko/20010505
BuildID:    2001050515

In the top left corner, Mozilla inserts a vertical space that shouldn't be
there. It ruins the whole design. It looks ok in IE. Some problem for
wwww.abcdnet.org

Reproducible: Always
Steps to Reproduce:
1. go to www.tehonet.net or abcdnet.org
2.
3.

Expected Results:  IE behaviour
http://www.abcdnet.org renders fine for me...  The other page seems to be
rendering just like NS 4.x would render it, which is correct in quirks mode.

Comment 2

18 years ago
I can't see what the site looks like with IE, but Netscape 4 and Mozilla do differ.
I can see a problem with Mozilla build 2001050306 in Linux.
The problem of the extra space can be shown with the following html:

<html>
 <body>
  <table border=1>
   <tr>
    <td valign="top">
     <p>
      <center>
      This line should be at the top
      </center>
     </p>
    </td>
    <td valign="top">
     <center>
      <p>
      This line should also be at the top
      </p>
     </center>
    </td>
    <td valign="top">
     <center>
      This line is at the top
     </center>
    </td>
    <td valign="top">
     <p>
      This line is also at the top
     </p>
    </td>
   </tr>
 </table>
</body>

The first cell (center tag surrounds p tag) is what is happening with the url.
I'll attach the html.

Comment 3

18 years ago
Created attachment 33499 [details]
html demonstrating extra space

Comment 4

18 years ago
Quirks behavior comes from the following rule in quirk.css:

body > :first-node, td > :first-node {
  margin-top: 0;
}

That's why the top margin is 0 if the <p> is the first child of the cell but not
if it has the <center> as a parent.

Now honestly I'd recommend this as minor evangelism because the <p> element is
not actually a paragraph in the page listed but is instead used for custom
formatting.

But if we're doing quirks we need to do them right... how to get the expected
behavior from css is tricky.  Maybe something like

td > :first-node, td > :first-node > :first-node {
   margin-top:0px;
}

That solves this specific instance.
--J

Comment 5

18 years ago
Closing the bug as I see the behavior of the attached test case is correct.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
SPAM. HTML Element component deprecated, changing component to Layout. See bug
88132 for details.
Component: HTML Element → Layout

Updated

18 years ago
QA Contact: bsharma → moied
You need to log in before you can comment on or make changes to this bug.